WordPress.org

Forums

Subdirectory multisite NOT Found (9 posts)

  1. GerBreOwn
    Member
    Posted 4 years ago #

    I just created a subdirectory multisite & when I try to visit that blog I get the following error message: "Not Found

    The requested URL /test was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

    Any ideas on why this is happening??? Thought the subdirectory is controlled by the database.

    Thanks

  2. GerBreOwn
    Member
    Posted 4 years ago #

    It now has started working like it should...

  3. mikedorey
    Member
    Posted 4 years ago #

    I still get this issue. What did you do to resolve it?

  4. Usually it's an .htaccess gaff.

    I remember you, mikedorey! It's possible your woes are BECAUSE IIS doesn't really do htaccess the same way.

    Sadly? I know jack about IIS :( But continue that info in your original post: http://wordpress.org/support/topic/problems-running-wordpress-on-iiswindows?replies=7

    That's the best way for it.

  5. GerBreOwn
    Member
    Posted 4 years ago #

    Part of my problem solved itself & I can see the subdir blog but when I try to go to any of the other dirs under that subdir it can't find them, i.e. wp-admin etc..

    Also the blog doen't show up with the themes.

    This is running on a Linux machine but is as a shared host so don't know if that is part of the problem.

  6. GerBreOwn - Again, normally an .htaccess gaff.

    What's in yours?

  7. GerBreOwn
    Member
    Posted 4 years ago #

    Tech support at my webhost said it has weird stuff in it. Here is what it contains that I copied from the Network Install instructions:
    "RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]"

    Any help on what should be in there will be greatly appreciated as I an new to Linux & Apache.

  8. Your .htaccess is correct for a SubDirectory install however it sounds like it's not being read.

    Try putting this on the top (ABOVE the WordPress stuff) of your .htaccess:

    <Directory />
    AllowOverride All
    </Directory>

    If that fails, tell your host that YES it has 'weird stuff' in it, but that's what it's supposed to have. And for some reason, apache isn't reading it. They should be able to turn on 'allow override' to fix that from the server level.

  9. duckheekim
    Member
    Posted 4 years ago #

    I had the same problem and just solved it.
    I guess that's mod_rewrite thing. (my platform is mac os x)
    Follow the steps showed in the following link. That's how I figured out the problem.

    http://www.deheus.net/petrik/blog/2005/02/11/getting-mod_rewrite-to-work-on-mac-os-x/

Topic Closed

This topic has been closed to new replies.

About this Topic