• Resolved jemar707

    (@jemar707)


    I have been stumped why sub forums are not being displayed in the main forum index. The only way I have been able to get the sub-forums to appear is by checking Box 7. Add Sub Forum Description to forum lists from the Forum Display tab. However, I do not want the descriptions. I just used that for testing purposes to see if it was related tot he problem.

    When I deactivate the plugin, the sub forums appear appropriately.

    On the referenced page that I need help with, there should be sub-forums listed under General Discussion.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Robin W

    (@robin-w)

    Thanks, what other bbpress related plugins are you running?

    Thread Starter jemar707

    (@jemar707)

    Hi Robin,
    Thanks for the quick reply. I am using quite a few. I just tested them one by one and it seems there might also be a conflict with bbPress Toolkit. When I disable that plugin, the sub forums also begin to appear correctly. Your plugin and that one have some overlapping features, but there are a few extra in that one I use.

    The others are:

    bbp User Ranking
    bbPress – Moderation Tools
    bbPress Do Short Codes
    GD bbPress Tools

    Plugin Author Robin W

    (@robin-w)

    ok, thanks – I’ll take a look

    Plugin Author Robin W

    (@robin-w)

    so in

    dashboard>tools>bbp toolkit>Do not show the table with the list of subforums, only show the current forum and the topics

    is this selected?

    Thread Starter jemar707

    (@jemar707)

    No, it is not selected.

    Plugin Author Robin W

    (@robin-w)

    thanks.

    On my test site, I have both plugins running and sub forums are displayed, so I suspect it must be a setting in one or the other.

    I have done a code search for the most likely duplicated functions, but cannot see any obvious conflict.

    So I’d suggest the following.

    1. go into dashboard>settings>bbp-style pack>export settings. That will save the current settings to your computer
    2. then do dashboard>settings>bbp-style pack>reset settings and reset them all

    That will give you a blank installation of my plugin.

    Then re-test

    If forums don’t display, then it is probably a settings in bbp toolkit, so then play with the settings in bbp toolkit to see if you can fund which one is affecting.

    If subforums now display, then we need to find which settings stops them displaying. so re-import the settings, and then reset half of the tabs. if it now works, then it was one of those tabs, if not it was one of the tabs you reset. By importing and resetting you should quite quickly be able to work out what setting is affecting.

    Thread Starter jemar707

    (@jemar707)

    I followed your suggestion and it definitely seems like the problem is bbPress Toolkit. I thought I would contact the plugin author but it turns out it’s not being supported any longer. I thought about not using the plugin entirely and there is a workaround for almost every feature I am using with the exception of two that are important.

    One of the features is actually also in your plugin but I can’t seem to make work is @mentions. I installed bbp-mentions-email-notifications plugin as suggested (note, this isn’t being supported anymore either) It isn’t sending a notification email after someone is mentioned. I could do away with the feature if necessary, but it is nice to have for the users.

    The other feature from Toolkit that I can’t let go of is the ability to close forums where no new topics can be created but replies are still allowed for existing topics. I will do some more digging to see if there is another method for this feature and then stop using bbToolKit altogether.

    So I guess for now I will have to be stuck without the display of sub forums in the forum index.

    Thank for you help with, I didn’t think it would end up being your plugin, since it is awesome! Let me know if you have any thoughts.

    • This reply was modified 2 years, 4 months ago by jemar707.
    • This reply was modified 2 years, 4 months ago by jemar707.
    Thread Starter jemar707

    (@jemar707)

    Nevermind about @mentions not working, I had to update the sending email address in another plugin and it’s working.

    • This reply was modified 2 years, 4 months ago by jemar707.
    Plugin Author Robin W

    (@robin-w)

    ok, on bbp toolkit – this works with my style pack on my site.

    So if you test the options, and can find which option is making it not work, then I can look at the code in toolkit and see if there is an easy fix.

    But I do need you to work out what settings(s) cause the issue.

    Thread Starter jemar707

    (@jemar707)

    Sorry for my slow reply. Our site is seasonal and busy right now. I will test this and get back to you as soon as I can. Thanks for your help so far.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Sub Forum Display’ is closed to new replies.