Sub-directory Site, 200 OK messages appearing on Page (5 posts)

  1. Zaggeh
    Posted 5 years ago #

    I just set up a fresh install of WordPress and configured networks using Sub-Directories. My main site works just fine http://clylla.com, but any additional site I create will periodically display and ugly message somewhere on the page:

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    HTTP/1.1 200 OK Date: Sun, 21 Nov 2010 08:31:33 GMT Server: Apache/2.2.14 (Unix) FrontPage/ X-Powered-By: PHP/5.2.13 X-Pingback: http://clylla.com/wptest2/xmlrpc.php Expires: Wed, 11 Jan 1984 05:00:00 GMT Cache-Control: no-cache, must-revalidate, max-age=0 Pragma: no-cache Link:; rel=shortlink Last-Modified: Sun, 21 Nov 2010 08:31:34 GMT Keep-Alive: timeout=5, max=99 Connection: Keep-Alive Transfer-Encoding: chunked Content-Type: text/html; charset=UTF-8 55f5

    When you submit a comment to the Hello world! post, it goes through and everything, but that message shows up at the top of the page.

    When you pull up the wp-admin dashboard, everything looks fine until it loads the content inside of "Other WordPress News", and then that error appears twice, both at the top and bottom, of the Other WordPress NEws box.

    If you try to make any changes to any settings/configuration in wp-admin area, that message shows up at the top of the page but everything still works.

    If you start typing out a new post, everything works but after a short delay that message shows up over-top/inside the WYSIWYG editor, along with the permalink and an edit button.

    I'm sure this is an issue with the Rewrite rules/conditions in my .htaccess file. But I don't know too much about that kinda stuff.

    I have read from other people's blogs/forums that my host (Network Solutions) handles mod_rewrite a little bit differently than others. But most of that information was very outdated and was covering a different type of error (500, 301, or the 200 OK message on a blank page). I went ahead and tried some of those solutions anyway, but they didn't work.

    One thing I read last night that sounded like it could be an issue was how Rewrite rules could wind up creating some sort of loop that might generate an error like that. But I don't really understand enough of it to know how to fix it, and that particular site didn't really cover it in detail.

    My .htaccess (Which is pretty much the default):

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    # END WordPress

    Any help?

  2. I think it's more how your host is handling the rewrite rules. :-/ those are all server-side errors. If they are periodically crapping out, or it's a cloud and something's being missed... yeah.

  3. Zaggeh
    Posted 5 years ago #

    Thanks for the reply. I have a post up on NetSol's support forums as well, but still no help there.

    Are there any simple things you can think of that I could do from my end to test and identify the exact issue?

  4. You coudl try disabling all your plugins, just to rule them out, but honestly...

    If you start typing out a new post, everything works but after a short delay that message shows up over-top/inside the WYSIWYG editor, along with the permalink and an edit button.

    To me, this means when the auto-save kicks in, it's getting a server error. Which is totally your host.

  5. sylviathewitch
    Posted 5 years ago #

    Hi all!
    @Zaggeh: have you ever found a solution to this problem?
    I am also with netsol and I have the very same situation :-(
    Netsol tells me, that it is a script error, but when I try the same settings on a website, that I host with a different hosting company, everything is working great.

    I would hate to switch hosts right now, so it would be nice to find a solution for that.

    Thanks all!

Topic Closed

This topic has been closed to new replies.

About this Topic