Sub category post - no comments (4 posts)

  1. hotkee
    Posted 10 years ago #

    Not sure if this is a bug or not.

    But I created a category (called C say) with a sub category (S).

    Then I created 4 test posts all with "All comments enabled". These posts are assigned to the categories C and S.

    No when I view the post, then click on the Comments link, it should come up with a form to enter a comment, instead it displays

    "Sorry, no posts matched your criteria."

    I also wanted a page where I could list the posts within the sub category S only.

    I searched the forums and found the sort of code that could work but try as I might, it fails to work. Has anyone got some code that would function. To me it seems a problem related to not being able query the database for the sub category for whatever reason.

  2. dommega
    Posted 10 years ago #

    I tried your problem on both 1.5 and 1.5.1 and had no problem. Did you modify the template at all?

  3. hotkee
    Posted 10 years ago #

    By template you mean comments.php? or similar include file?

    It could be a database problem because I installed 1.5 upgraded to 1.51.

    Then reused the database with a new set of files from 1.5.1

    I have tried several themes, all give the same problem.

    If you say yours is working, I guess mine is badgered, I will re-install afresh and see if it works.

  4. hotkee
    Posted 10 years ago #

    Ok figured the comments out myself, doh.

    Permalinks structure WAS set to /%year%/%monthnum%/%day%/%postname%/

    then I made it blank for some other testing I was doing, left it blank and comments do not work, put the permalinks structure back to


    then it works, problem solved, DOH!

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.