Support » Plugin: Remove Category URL » Sub-categories 404ing

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter robertsheacole

    (@robertsheacole)

    Let me clarify something I noticed. When I create a sub-category I can get to the sub-category page by just putting the sub-category name after the forward slash, like http://www.mysite.com/sub-cat

    But, http://www.mysite.com/parent-cat/sub-cat does not work

    However, when I go to an individual post in my sub-category I can see the parent category and sub-category in the url before the post title

    For example: http://www.mysite.com/parent-cat/sub-cat/post-name

    I would love to have the parent category and sub-category names in the url for the sub-category page itself. Is there a way to accomplish this?

    Have you tried using a trailing slash on the sub-category URL?

    The plugin supports what you’ve described so I’m not sure why it isn’t working for you.

    Thread Starter robertsheacole

    (@robertsheacole)

    Mario, thanks for your quick reply. Yes, I have tried that with no luck. However, what does work when I want to go to the sub-cat category page (not an individual post) is to put the parent category “name” instead of its slug into the url.

    For example: http://www.mysite.com/parent-cat-NAME/sub-cat-slug

    But…

    When I want to go to a post in that sub-category the url is:

    http://www.mysite.com/parent-cat-SLUG/sub-cat-slug

    Why the “name” in one url and the “slug” in the other? This doesn’t make any sense!

    I haven’t heard of that particularly variation before. Have you tried refreshing the permalinks of your site?

    1. Go to this page: /wp-admin/options-permalink.php
    2. Make note of your current permalink structure.
    3. Select Plain and save.
    4. Put your preferred permalink structure back in and save again.

    Other than the above, I don’t know what else to try. Are you familiar with WordPress’ debugging functionality?

    Thread Starter robertsheacole

    (@robertsheacole)

    Saving the permalinks does not work either.

    And another problem that I found is that a sub-category’s page navigation breaks. Page navigation only works on top level navigation. This is not good.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Sub-categories 404ing’ is closed to new replies.