WordPress.org

Support

Support » Plugins and Hacks » Styling for subtitle not working

Styling for subtitle not working

  • I used the following code to style my subtitle in my template but it does not style accordingly. I have attempted to use other php get codes and it styles fine. Why is this so?

    $postheader .= '<h3 class="entry-title"><a href="' . get_permalink() . '" rel="bookmark">' . get_the_title() . '</a></h3>';
    
    	$postheader .= '<div class="subtitle">';
    
    	$postheader .= '' . the_subtitle() . '';
    
    	$postheader .= '</div>';

    Also, I have attempted the technique mentioned in another thread to style the code but, like my current example, it always snaps to the top (for positioning) and sometimes does not even show the font css style I have implemented.

    Over here in the code you can see that I attempted to place the subtitle after that ‘h3’ title, but the result appears such that the subtitle comes before the ‘h3’ title. This is pretty frustrating.

    My website is at http://www.welovesingaporeproperty.com/.

    A screenshot of the problem is here: https://www.dropbox.com/s/u044domth59n2zk/Capture.JPG

    http://wordpress.org/extend/plugins/subtitle-360/

Viewing 1 replies (of 1 total)
  • Plugin Author HasanulBanna
    Member

    @hasanulbanna

    Hi,
    Please note the the funtion echo its left so there may be problem while you concatenate it with a variable.

    Why you cant style it like this?

    <div class=”subtitle”>
    <?php the_subtitle() ?>
    </div>

    You an use position absolute and relative to display it above a image 🙂

Viewing 1 replies (of 1 total)
  • The topic ‘Styling for subtitle not working’ is closed to new replies.