Support » Themes and Templates » Styling for Byline

Viewing 14 replies - 1 through 14 (of 14 total)
  • could you please post a link to your site?

    If you look in your themes main index template you should see some text that looks like this
    Filed Under <?php some code?> | <?php some more code ?>
    I’ve omitted specific code

    You could just enclose this in a span tag with a new class and style it in your style sheet

    <span class="byline">Filed Under <?php some code?> | <?php some more code ?></span>

    In your style sheet

    .byline {
    Your css code goes here;

    I’m afraid not – it’s set up on an intranet.
    If it helps, I am using t5he Modernpaper Theme – here is a screenshot

    Thanks , I can see that that should work, but it just isn’t.
    It’s not picking the style up from the PHP.

    Okay lets do this.
    First let me ask does the byline appear on the main page and the single post page if it does then paste both of these separately to and report the link back here. If not just paste the one that the byline appears on.

    Ah – now that you’ve said that I have noticed that it is working on the single page but not on the front page.
    So do what is it that I need to paste up for you?

    The main index template controls the front page.

    Ok, here is the index.php from the template directory.
    The line in question is Line 8.

    That looks correct. Have you cleared your browsers cache after the change. Also do you run wp-cache or super-cache if so you’ll have to clear that cache as well.

    I’ve cleared my browser cache to no avail.
    I have no idea about wp-cache or super-cache so, unless they run by default, the answer is probably that I don’t use them.
    It’s all a bit of a mystery.

    I don’t know if this has any bearing on this (as in perhaps pointing to a deeper problem with the installation) but I noticed that if i change the permalink options to date/name format, the links to the single page won’t work – even on refreshed pages.
    Changing the permalinks back to the default method returns their functionality

    Is it an apache server if not then only the default permalinks will work. But this shouldn’t affect your styling. Try this
    <p class="byline">Code</p>
    remove the span tags and just add the class to the p tag itself.

    It is an Apache server.
    I already tried giving the classID to the P tags.
    It didn’t work – or, rather, it doesn’t work on the front page.

    Ah! Found it – in the Theme Editor there is a link to home.php . I put the byline-classed tags in there too and it works.
    That’ll teach me to use Dreamweaver instead of the tools at hand 🙂
    thanks for all your help Jeremy.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Styling for Byline’ is closed to new replies.