Support » Themes and Templates » Stylesheets plugins do not load

Stylesheets plugins do not load

  • It seems that the stylesheets from a couple of plugins don’t load in my theme. The elements stay unstyled (links blue, purple, etc.)

    How can this be resolved?

    A lot of thanks in advance.

Viewing 15 replies - 1 through 15 (of 15 total)
  • whooami



    uploading the stylesheets usually.

    provide a link to your blog, and specifically a link to page within it where thats happening.

    The stylesheets are online, in the plugin directory where they should be. I’ve started to build a new theme, from scratch, in other themes this does not happen.

    (The theme isn’t public yet, because it is in construction)




    not to be rude or testy, but, for future reference, we ask for links for lots of reasons — one of the reasons is because people come here, say things, ALL OF the time — and then we go “look” and what they said — isnt the case.

    youre saying it, doesnt necessarily make it true. it happens all of the time.

    if its your theme, and you see the stylesheets in the head when you view the source, than copy and paste the links to the stylesheets into your browser. Do the stylesheets load then?

    Additionally, since you mention that its a theme you are creating, what are you using as a guide? the defualt theme? the classic theme? something out the vast wild blue yonder?

    themes have necessary items in them. one such item is wp_head


    I suggest taking a look at the codex and some other themes as you go forward.

    Okay, I get what you’re saying. I only describe what I see (not saying that it is the truth) to let you get a view of what is happening, and hoping that you’ll recognise it.
    I don’t think you’re rude, just explaining. Thanks for your patience.

    Though, I added the function wp_head in the header. It solved the problem for one plugin. (Mostly, I only have to edit the stylesheet of the plugin, but that’s ok enough I think…)

    I did use a reference, but not the default or the classic theme. Just starting with the basic stuff, then extend it with more functions and stuff.

    When I copy and paste the stylesheets from the head, it loads. That’s saying something, sure… I said it doesn’t load, but I can see it existst, so it only seems to be not loaded.
    Also the .js files do load when I copy and paste the URL.

    I did look at other themes but don’t understand the WordPress-language fully, I’m trying to learn. So I started with some clean files, building a theme.

    If you still need to see my theme in action to help me further, let me know.



    Forum Moderator

    It could be that the order in which the stylesheets are being loaded into the page. Sheet 2 might be over-riding Sheet 1 etc.

    If you use Firefox, install Firebug. It’s invaluable for troubleshooting these kinds of multiple sheet/cascade problems.

    I’ve got firebug and I’ll take a look if changing the hierarchy solves the problem.

    That doesn’t make a difference i think, the most important one is on top, the other stylesheets are below that one. I edited one stylesheet to got the right look. Thanks.

    I don’t know how to solve the other plugins problem. It has images, which do not show. I’m talking about Sexybookmarks. But I don’t know if this is enough information for you to help me.



    Forum Moderator

    Don’t know Sexybookmarks. I’ve obviously just been using PlainBoringBookmarks. 🙂

    Are the images applied using CSS? If so, does Firebug give any indication of what image path is being used?

    Oh crap. I typed a reply, and then it was gone.

    But okay.

    It looks like some effects are defined in the .css of the plugin. With gradient-png’s for example. But there aren’t any icons of the socials located in the /images folder from the plugin.

    The code looks like this:
    <ul class="socials"><li class="sexy-delicious"><a href="http://del.icio.us/post?url=http://urlhere" rel="external nofollow" title="Share this on del.icio.us">Share this on del.icio.us</a></li>

    Only the text ‘share this on del.icio.us’ is being displayed.

    So where are the images coming from?

    It’s really confusing me…



    Forum Moderator

    List bullets? Anything relating to list-style-image in the plugin’s css?

    list-style-type:none !important;

    I cant find the images anywhere… Maybe they are hosted elsewhere, but I also can’t find where that is defined : ).

    I think I found it. In the readme:
    I’ve uploaded the plugin and activated, but it’s not showing up or it’s brokenÖ =

    This is normally due to styles in your WordPress theme overriding the styles of the plugin. Check your theme’s stylesheet for rules like !important; as these may be overriding the styles defined by the plugin.

    I’m going to try that and let know.

    Still doesn’t work : (
    Uhm my theme style doesn’t have !important in it but ok.



    Forum Moderator

    Could be a specificity issue. For example:

    Simplified Markup Structure:
    .post – [ post content goes here]

    In this situation, if you’ve styled lists in your main sheet using:

    #content ul li {list-style-image:url(images/bullet.gif;}

    and a plugin css sheet that loads later uses

    .post li {list-style-image:url(images/bullet2.gif;},

    you’ll find that the plugin’s css won’t display.

    #content trumps .post in this case.

    That’s where Firebug helps by also displaying what styles have been superseded by later, or more specific, css.

    I’m having this same problem with “I love social media” plugin. The stylsheet does not show up.


    Please help!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Stylesheets plugins do not load’ is closed to new replies.