Support » Fixing WordPress » Style Switcher Problem

  • I had Alex’s style switcher working great with 1.0, but I can’t seem to get it to work with 1.2. The problem seems to be this:
    The instructions say to find and replace the line
    @import url( <?php echo $siteurl; ?>/wp-layout.css );
    and replace it with
    @import url( <?php wp_stylesheet(); ?> );
    BUT Mingus 1.2 final does not have this line, it has
    @import url( <?php echo get_settings('siteurl'); ?>/wp-layout.css );
    So, it seems that Mingus uses a slightly different method for getting the style sheet. Anyone know how to adapt Alex’s line to make the style switcher work with Mingus?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Just replace it, shouldn’t matter. If it isn’t working give us a link to your blog and we will go from there.

    It’s one of my hosting client’s blogs, so I’m not sure if they would want me publishing the link(not sure why they would mind either, but better safe…)
    I have already tried just replacing the line. All styles in the wp-style folder are listed on the main index page with links “http://www.site.com/blog/index.php?wpstyle=blue&#8221;, etc. However, clicking on any of the links just results in wp-default being loaded.
    I’ve also tried installing the hack the “old way”, using my-hacks.php as with 1.0, but I had the same problem. That’s why I thought that maybe the style sheet is being called differently in 1.2.

    cookies turned on?

    Yes, cookies are on. In fact, the example switcher on Alex’s site works fine.
    I had the switcher working fine with 1.0 on the same server and no PHP settings have been changed.

    Just for the record, I had exactly the same problem and was never able to get it to work. I just gave up.

    Next question – where is the index page in relation to the rest of the WP files?

    Glad you got it, that was going to be my next suggestion. I had tested converting the style-switcher to handle the index page in the root directory and when I switched it back I had to delete the cookie in order for it to work again.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Style Switcher Problem’ is closed to new replies.