Support » Themes and Templates » Style not loading on Firefox

Viewing 8 replies - 1 through 8 (of 8 total)
  • Try putting ” on either side of the url for the stylesheet. The odd thing is if I use one of the stylesheet editors for firefox the stylesheet then loads, they obviously read them differently.
    @import url("");

    Do you have the Web Devloper extention installed? If so, check to make sure you haven’t accidently set it to disable all styles. (Ctrl+Shift+D) will toggle it.

    Okaaay… never mind that….. I see now that it doesn’t work for me either…..
    Just for fun, change your style link to this:
    <link rel="stylesheet" href="<?php echo get_settings('siteurl'); ?>/wp-layout.css" type="text/css" media="screen" />

    Your problem is the content-type that your server is sending with your .css files. It should be sending text/css but is actually sending text/plain.
    You can see this by entering the address of one of your stylesheets at
    Because your server is running the Apache software, simply placing the following code in the .htaccess file in the root of your site should solve your problems:
    AddType text/css .css

    I wanted to add another thanks to michaelward82 for this fix. I was doubtful that adding the AddType Apache directive would actually fix the problem; but alas – it did.

    I have to join crowd and add my thanks for this fix. Like Stanoman I didn’t think adding the directive was the answer, but since I’d tried everything else with no luck, I tried it. Instant fix. 🙂 Thanks so much!

    Talk about the magic bullet. I’m a less than competent coder (sorry to add to the mess…) and have been working for several days trying to fix this same problem. I knew it had something to do with the content-type misdirection from my multiple red flags in my Firefox’s JavaScript Console. Thanks michealward82 for providing the answer in 20 characters or less!

    I’m having similar issues on — users of Firefox are occaisionnaly seeing unstyled content- a Shift-Reload clears it, but people think the site is broken.

    The magic bullet did not work as the tool (a great one to have, so thanks) indicates our Apache server is sending it as text/css.

    Also, just cleaned up 4 CSS validation errors (now validates). Also noticed that my CSS file had Mac encoded line returns, changed to unix (might that be an issue??)

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Style not loading on Firefox’ is closed to new replies.