Support » Plugin: Yoast SEO » Stupid updated

  • Update increasingly stupid, media attachment index that affects the ranking, remove the noindex subpage feature makes the entire website was warning duplicated. Stupid is the word for the recent version. Rely on a blog post on Google’s blog since 7 years ago and index the entire pagination, then make sure it’s good for SEO, stupidity.

    • This topic was modified 2 years, 10 months ago by cluin.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support monbauza

    (@monbauza)

    Hi @cluin,

    Thanks for your comment.

    We apologize for any inconvenience this has caused you.

    Unfortuntately, there was a bug in Yoast SEO 7.0 where some settings were not properly migrated after updating to v7.0. The bug was completely fixed in v7.0.3 so you should no longer experience problems with the Yoast settings being migrated incorrectly. Please, refer to the changelog for more details: https://yoast.com/wordpress/plugins/seo/change-log-wordpress-seo/

    For some users, this caused the attachment pages to be indexed, as the index setting was not correctly imported from the previous plugin version. We’d suggest going to “SEO > Search Appearance > Media” and:

    1. Make sure that your attachment pages are redirected to the attachment itself or, alternatively,
    2. Toggle the “Show Media in search results?” button to No

    Either action will make Google update its index and remove these pages from the search results. As much as we’d like these changes to happen instantly, it may take Google some time to reflect them in the search results. Re-submitting your sitemap index to Google Search Console may speed up this process.

    On the other hand, we removed the feature to set the subpages to noindex in Yoast SEO for WordPress v6.3. Please feel free to refer to this article for more information as to why we removed that feature and why it’s more beneficial to index the subpages https://yoast.com/pagination-seo-best-practices/

    Plugin Support monbauza

    (@monbauza)

    Hi @cluin,

    Joost has just written a new post explaining the best possible solution to remove your attachment URLs from the search results: https://yoast.com/media-attachment-urls/

    Hi, I have the same issue, I´ve updated and installed the Search Index Plugin but something gone wrong with the configuration wizard, is it ok if I check manually all the options? The error with the wizard appeared even when Yoast was the only active plug in 🙁

    Plugin Support monbauza

    (@monbauza)

    Hi @estehelecho,

    Thanks for your comment.

    Can you please create a new topic in the WordPress.org forum so that our support team can assist you? Please, include a description and a screenshot of the error.

    That being said, if you’re having problems with the Yoast configuration wizard, you can manually set up the plugin by following these steps: https://kb.yoast.com/kb/yoast-seo-installation-wizard/

    Thank you for a quick answer! I´ve set up Yoast manually. And installed the Search Index Purge.
    I checked the sitemap generated by Yoast and it has two URLs with attachements, last week it doesn´t show any URLs for attachements, it had just 3 URLS (it was wrong) but is it normal that nowadays my XML Sitemap Index file contains 2 sitemaps of attachements? They had 80 urls each one, the same URLs. Some of them are grey because they are not existing pages (404 errors).
    I don´t know if the 2 attachement sitemaps are a correction of the previous error, or if they are a current error, I´m afraid of duplicated content.
    Could you help me? I´ve posted this in the support forum also, thanks!

    Plugin Support monbauza

    (@monbauza)

    Hi @estehelecho,

    Our support team has replied to the topic you created in the WordPress.org forum: https://wordpress.org/support/topic/two-attachement-urls-in-xml-sitemap/ We’d appreciate it if you could provide them with additional information.

    Thanks!

    • This reply was modified 2 years, 10 months ago by monbauza.
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Stupid updated’ is closed to new replies.