Support » Installation » Stupid stupid question

Stupid stupid question

  • I’m upgrading to 1.2 finally. At first I just uploaded everything from the download file on this site. Then I realized I should delete everything pertaining to wordpress on my server. So I did and I still get this:
    You appear to already have WordPress installed. If you would like to reinstall please clear your old database files first.
    What else do I have to delete?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Run upgrade.php, not install.php ?

    Like I said, a stupid question. Thanks a lot. I think I tried looking for stuff on upgrading, obviously not hard enough.

    I’m having problems again. The upgrade.php worked. But I’m getting this:
    Warning: main(/home/sandy/public_html/litaloo/wp-includes/wp-db.php): failed to open stream: No such file or directory in /home/sandy/public_html/litaloo/wp-settings.php on line 30
    Fatal error: main(): Failed opening required ‘/home/sandy/public_html/litaloo/wp-includes/wp-db.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/sandy/public_html/litaloo/wp-settings.php on line 30
    I know its probably something simple but I just cant figure it out. I’m new to this whole thing, obviously.

    Did you upload this file ? ‘wp-includes/wp-db.php’ ?
    If yes, try running upgrade again.

    I forgot to mention that its when I hit ‘login.’ If that makes a difference. But yeah, wp-db.php was uploaded, and I tried upgrade.php again. It worked and took me to the index file, and from there I went to click on ‘login’ (register does the same thing) and I got that same message.

    My guess would be to delete wp-dp.php from the /wp-includes folder, and re-upload just that file.
    Something funky could have occurred on upload.

    Nope, same thing.

    Are you doing the two directory thing ?
    It doesn’t look like it from here, but the inital error is just a way of saying “the file isn’t there” so I’m about out of ideas ….

    I dont know what you mean about the two directory thing, but if its what I think then no. Might it work if I just try to re-install the whole thing again?

    You could delete the wordpress files from the server, upload, run upgrade again…

    alright, I’ll try that.

    I did that and now it works so far. I did it different this time. Before, I was uploading it into its own folder so that it wouldnt be so disorganized. And this time I just put it in the root folder and it works. Why didnt it work before?

    Dunno … the mysteries of code 🙂
    Glad all is well though !

    Thank you so very much!!

    There are no stupid questions.
    I’m wondering if the problem was with the URI you supplied in the WP options? Just a guess. Glad it’s working. Podz is a great helper. He even does windows (and I don’t mean the Operating System).
    If nothing else, simply chalk it up to the Sushubh Effect, and don’t worry about it.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Stupid stupid question’ is closed to new replies.
Skip to toolbar