Support » Fixing WordPress » stupid mistake in WordPress Address (URL)

  • I made a stupid mistake. In WordPress Address (URL) and in Site Address (URL) I changed http://localhost/site into the real url. Stupid, I know. How can I change it back? I can’t enter the WP backend anymore.

    It’s on my own pc, and I have full access to everything.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I fixed it myself. Not difficult, once you know how to do it. For those making the same error:

    go to php myadmin > wp_options table, and change the entries manually.

    Keith

    (@keithdriscoll)

    There are many ways to change the site URL.

    In your instance I would edit functions.php and add the following code:

    update_option( 'siteurl', 'http://example.com' );
    update_option( 'home', 'http://example.com' );

    and replace example.com with your url. This will update the option and can be removed afterwards.

    https://codex.wordpress.org/Changing_The_Site_URL

    Me also… made the same mistake as Josflachs…. on my WP Admin page, I changed the WordPress Address (URL) bar from https://www.xxx.com/wp to https://www.xxx.com/wp/home… resulted in me not being able to log into WP Admin… how do I change it back if you can assist please? I have access to my files through Cp on my server.

    Problem solved already thanks… went myPHP and edited the URL…..

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘stupid mistake in WordPress Address (URL)’ is closed to new replies.