Support » Plugin: Comments Evolved for WordPress » Stumped – one install works, one doesn't.

  • Resolved olavf


    So I rolled out the plugin yesterday on my photography site, and it works like a charm, though there are some CSS issues with FB and Facebook (I can’t remember if they existed pre-1.3.0) where the text is black on my gray background (unlike the white background of the G+ tab).

    I tried loading it on one of my other sites, and am getting no joy though. I’ve tried disabling nearly every plugin that could possibly affect a blog post, and it just won’t load – all I get is the WP comment box.

    There are some differences in installs that may be a clue, so I’m looking for ideas. On the site that works, I was able to use a verified email address to link the pages back. For this site, however, I had to use the alternate method of adding code to the site – I don’t have any email addresses associated with the URL. So, I’m using the Google Author Link plugin ( which passes Google verification, and I’ve also tried hard-coding it in the footer instead (which also passed).

    Theme is ‘Origin’ by Alien WP (

    Sample page is here –

    TIA, Olav

Viewing 10 replies - 1 through 10 (of 10 total)
  • I’ll see if I cant check into it this afternoon

    Thanks Brandon – no rush since this site only really gets traffic when I cook, but if it’s a functional issue, I’d really like to see your plugin succeed – I played with it a bit on G+ last night, and it’s pretty much what I’ve been looking for in a commenting system.

    it looks like the theme is loading the comments a bit strange …

    try changing the

    <?php comments_template( '/comments.php', true ); // Loads the comments.php template. ?>
    <?php comments_template( '', true ); ?>

    in singular.php of the theme

    That didn’t seem to have any effect.

    I forgot to mention that Disqus does work if I enable it though.

    It’s definitely thematic, though. I switched over to twenty-ten on a hunch, and it works.

    So you’re probably right – it’s somewhere in how the comments are loaded but I don’t know enough code to be able to find it.

    fyi – i had similar issue in that the plugin did not work with many of my Theme Hybrid Parent and Child themes so i reached out to Justin and he said the following (see below) and that worked … so now your plugin works great in my responsive child theme – way cool … hope this helps … cordially, chuck scott

    from this thread ->

    Add this to your theme’s functions.php file:

    remove_filter( 'comments_template', 'gplus_comments_template' );
    add_filter( 'comments_template', 'gplus_comments_template', 99 );

    Basically, the plugin isn’t adding it’s filter late enough. This is a problem I often see with these types of plugins.

    @chuckingit great! ty very much and I’ll change the priority for the filter in the plugin its self. Thanks for the tip-off.

    I cant see the support thread myself ( not a customer ) but please send my thanks to them as well 🙂

    Version 1.4.4 bugfix release that now runs at a higher priority now available.

    Justin Tadlock


    WordPress God


    Thanks for updating that. I think you’re one of the first plugin authors that actually took my suggestion for using a higher priority on this filter hook. I know it’ll save both of us from a headache or two down the road. 🙂

    @brandon – that fixed the problems with the Origin theme too.


Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Stumped – one install works, one doesn't.’ is closed to new replies.