Support » Plugin: Social Sharing Buttons | WPSSO Add-on » StumbleUpon Badge

  • Resolved danielbair

    (@danielbair)


    StumbleUpon Badge is not working with the latest StumbleUpon official Badge code update.
    The developers of this plugin need to update their code for StumbleUpon Badge to work again. See http://www.stumbleupon.com/dt/badges/create for the correct StumbleUpon Badge implementation method.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author JS Morisset

    (@jsmoriss)

    I’m not seeing any difference in the markup and the button appears to be working fine on my test sites. What changes have you noted? Please provide a URL to an example post/page on your site – with a non-functioning stumbleupon button – and I can have a closer look.

    js.

    danielbair

    (@danielbair)

    Sorry, I assumed there was a bug after a quick compare with another social sharing button plugin that is working correctly for the stumbleupon badge.

    Here is the website I am working on https://jesus4asia.org/project/widows-sewing-school/ and the buttons in question are at the bottom of the page (the other plugin buttons are up in the excerpt).

    I have tested on the latest Firefox and Safari browsers.

    Thanks for looking at this.

    Plugin Author JS Morisset

    (@jsmoriss)

    You’re using another plugin which is adding non-standard / custom markup for a stumbleupon button. Have you tried disabling that other stumbleupon button?

    You have a few HTML syntax issues as well that you should probably fix (it shouldn’t affect the stumbleupon button though): https://validator.w3.org/nu/?doc=https%3A%2F%2Fjesus4asia.org%2Fproject%2Fwidows-sewing-school%2F

    js.

    danielbair

    (@danielbair)

    I’ve disabled the other sharing buttons plugin. Still the WPSSO StumbleUpon button is not working.

    I don’t know what is causing the html syntax issues, though.

    danielbair

    (@danielbair)

    I did find a plugin that was inserting divs in the html header. It was one I forked so I just changed it to insert in the wp_footer and that cleaned up much of the html syntax issues. Still the WPSSO StumbleUpon badge isn’t showing.

    My console debugger is hinting that it might be due to the website I am working on being all in https, and the StumbleUpon badge is loading http scripts.

    Blocked loading mixed active content “http://cdn.stumble-upon.com/js/badge_su.js?v=20120613”[Learn More]
    Blocked loading mixed active content “http://cdn.stumble-upon.com/css/badges_su.css?v=20120613”[Learn More]
    Plugin Author JS Morisset

    (@jsmoriss)

    You’re correct. A Google search finds similar results, and I just tested the StumbleUpon button on an https test site to double-check. Although the StumbleUpon widget.js javascript appears to handle http / https correctly, it looks like their CDN is not (so css/js files coming from their CDN are http only).

    I’ve added a warning to the StubleUpon settings metabox to inform users of this fact. Hopefully, as most sites move to https, StumbleUpon will get an SSL cert for their CDN. 😉

    js.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘StumbleUpon Badge’ is closed to new replies.