WordPress.org

Support

Support » How-To and Troubleshooting » Stuck trying to insert an image into a custom homepage template

Stuck trying to insert an image into a custom homepage template

  • I just cannot figure out what is wrong with this… I am trying to insert an image into the homepage template that I created, but it just doesn’t show up. I am running WP on localhost and I have placed the picture in the theme’s image folder (atahualpa). Any idea? Thx.

Viewing 4 replies - 1 through 4 (of 4 total)
  • so when I am trying this ” <img src=”./images/picture.png” width=”40″ height=”65″ alt=””> ” it doesn’t show anything. If anyone has at least one suggestion I could follow…

    I have the same problem.

    The reason for this is because the link ./images/picture.png doesnt actually exist (e.g. http://www.domain.com/images/picture.png will not find anything.), this is because the theme folders are all created through functions in the main wordpress code.

    my attempt (which did not work) was to include the uri into the source of the file with php, It ended up having lots of unknown symbols :S

    If anyone else has an idea on how to solve this, please let us know 🙂

    Thanks

    found a sollution:

    <img src=”<?php bloginfo(‘template_url’); ?>/images/picture.png” />

    that one was bugging me 🙂

    mirroreflex
    Member

    @mirroreflex

    try using this html tag for picture:
    <img src="<?php bloginfo('stylesheet_directory'); ?>/images/yourimage.gif" width="xxx" height="xxx" title="title for picture" alt="alt for picture" />

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Stuck trying to insert an image into a custom homepage template’ is closed to new replies.