WordPress.org

Forums

[resolved] stuck on step 2 (7 posts)

  1. paulfern
    Member
    Posted 9 years ago #

    I'm stuck here:
    Second Step

    Now we’re going to create the database tables and fill them with some default data.

    Fatal error: Call to undefined function: populate_options() in d:\gearhost\hostingaccounts\prothumian\www\paulandmichele\wp\wp-admin\install.php on line 140

    ...I created a user with proper privileges and edited the config file. The system *is* includng the file that calls in populate_options().

    I want to migrate away from pmachine 2.3... help please :)

    My hosting co uses IIS w/php4 and mysql... I know pmachine had to have a tweak to run properly. Is there a similar tweak needed here?

  2. skippy
    Member
    Posted 9 years ago #

    populate_options() lives in upgrade-schema.php. Sometimes these errors occur because a file was not uploaded in ASCII mode. Can you try re-uploading upgrade-schema.php, taking care to use ASCII mode for the upload?

  3. paulfern
    Member
    Posted 9 years ago #

    I did that, and it got through. I am noticing a large slew of PHP warnings (this must be something to do with my hosting company..?) such that I log in and get nothing but these warnings.

  4. That could be related to your hosting company, or it could be that most of your files were not uploaded in ASCII mode. Since you're just starting out, it may be better to dump the database, delete the files, and try again (making sure that every file is uploaded in ASCII mode).

  5. paulfern
    Member
    Posted 9 years ago #

    I just finished a re-upload using FireFTP, which properly set to ascii. (It's this upload tool that got me past step 2 btw).

    Still getting these messages, which are basically cookie settings. It appears the include file before these calls is trying to put something out...?

    Warning: Cannot modify header information - headers already sent by (output started at d:\gearhost\hostingaccounts\prothumian\www\paulandmichele\wp\wp-config.php:22) in d:\gearhost\hostingaccounts\prothumian\www\paulandmichele\wp\wp-login.php on line 7

    Warning: Cannot modify header information - headers already sent by (output started at d:\gearhost\hostingaccounts\prothumian\www\paulandmichele\wp\wp-config.php:22) in d:\gearhost\hostingaccounts\prothumian\www\paulandmichele\wp\wp-login.php on line 8

    Warning: Cannot modify header information - headers already sent by (output started at d:\gearhost\hostingaccounts\prothumian\www\paulandmichele\wp\wp-config.php:22) in d:\gearhost\hostingaccounts\prothumian\www\paulandmichele\wp\wp-login.php on line 9

    Warning: Cannot modify header information - headers already sent by (output started at d:\gearhost\hostingaccounts\prothumian\www\paulandmichele\wp\wp-config.php:22) in d:\gearhost\hostingaccounts\prothumian\www\paulandmichele\wp\wp-login.php on line 10

    Warning: Cannot modify header information - headers already sent by (output started at d:\gearhost\hostingaccounts\prothumian\www\paulandmichele\wp\wp-config.php:22) in d:\gearhost\hostingaccounts\prothumian\www\paulandmichele\wp\wp-login.php on line 11

  6. paulfern
    Member
    Posted 9 years ago #

    OK - the error was that I had an extra few blank spaces in wp-config.php... thanks for your help.

Topic Closed

This topic has been closed to new replies.

About this Topic