• Resolved rogueeasyweb

    (@rogueeasyweb)


    We used the plugin on our site, pre-launch. We had google crawl the site when the plugin was turned on. Now, we are having trouble getting google to index the site. This could just be Google taking it’s time, but I wonder, could the plugin cookie be cached at our host (Siteground) and google still thinks the site is basically all no-index? I did clear the cache at Siteground. I’m just getting paranoid now and the client is not happy. Any thoughts?

    Search Console Screenshot:
    https://rogueeasyweb.tinytake.com/msc/Nzg0MDUzMV8yMDkwOTU0Nw

    Using this plugin seems extremely dangerous for SEO. ?

    • This topic was modified 1 year, 2 months ago by rogueeasyweb.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Muhammad Haseeb

    (@haseeb0001)

    @rogueeasyweb Hi,

    If you are using a caching plugin or web hosting such as WP Engine or SiteGround that has in-built caching, you will need to configure the caching service to be disabled if the Password Protected cookie is set.

    Thanks

    Thread Starter rogueeasyweb

    (@rogueeasyweb)

    Hello Haseeb,

    The plugin is currently no longer in use, the plugin is now deleted. Our problem was that, it was in use during testing and google crawled the site, and saw the no-index tags for all pages. We removed the plugin completely and then launched the site. To our dismay, we are having a hard time getting google to index our site pages. I have cleared the server/hosting cache several times. Is there any test we can run to see if the cookie is stuck in the cache on the server? I realize that this may also simply be due to how google takes it’s time to make index changes. But I was hoping you had some advice for us.

    Thank you.

    Plugin Support Muhammad Haseeb

    (@haseeb0001)

    @rogueeasyweb Let me test this case on my staging website and get back to you soon with updates.

    Thanks

    Thread Starter rogueeasyweb

    (@rogueeasyweb)

    Ok. As an update from me, we do have our pages indexed now. But, I had to manually request indexing in Search Console for every page.

    Plugin Support Muhammad Haseeb

    (@haseeb0001)

    @rogueeasyweb

    I have discussed it with it my SEO team, and it’s not the issue of a Password Protected plugin; if you disabled the plugin, then there will be issues with your website SEO like sitemap, robot file, etc, so please discuss this issue with any SEO expert and also share your website link so we can check also.

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Stuck on no-index with google’ is closed to new replies.