Support » Plugin: The Events Calendar » Stuck on month

  • Resolved samueljclemens

    (@samueljclemens)


    I’m running WP 5.4.1 and The Events Calendar 5.1.1.
    The theme is called “Ed School”

    My problem: I have a page with my events calendar –

    https://www.volksschule-herbststrasse.at/events/

    – with default view set to “month.” When you click on the left/right arrows, the page reloads but you stay on the same month. But the URL changes to

    https://www.volksschule-herbststrasse.at/veranstaltungen/monat/

    My site is set to German, and “veranstaltungen” is “events” in German. Maybe this is part of the problem. I tried setting the site language to English and got the same problem, but when I click on the month navigation arrow and the page reloads, still showing the same month, the URL now looks like this:

    https://www.volksschule-herbststrasse.at/events/(/?:month|monat)/

    The same thing happens (view stays on same month but URL chagnes to the one above) when I try to change the calendar view from month to day or list.

    Strangely, clicking on the name of the month and navigating to another month from the drop-down menu works, but only when I am logged onto wordpress.

    What I have tried:
    -deactivating all plug-ins except The Events Calendar
    -switching to 2016 and 2020 themes (with plug-ins deactivated)
    -changing most of the settings on The Events Calendar

    none of this stuff worked. Any help would be appreciated!

    Best, David

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • I have the same question, after the last update this happens. But no one is helping here. If you find something please say it

    I tried switching my working English localhost test site to German and updated the translations. Events then didn’t switch between (new format) list, month and day.

    Back to English and it worked again.

    I didn’t see (/?:month|monat) which looks like a translation query issue.

    This post is linked I think
    https://wordpress.org/support/topic/slug-translation-problem/

    Maybe also this one
    https://wordpress.org/support/topic/events-with-multiple-views/

    Thanks for that. Yes, from settings my site Language is in Greek, when i change it into English works fine. Translation issue

    I think I may have found the problem.

    On the TEC settings page change “events” to “veranstaltungen”

    It now works on my system for German.

    Maybe similar issue for Greek.

    had the same issue and found the same fix…changing site settings to english resolves the issue

    jim5471@ You mean from The Events Calendar General Settings-> Events URL slug-> change this?

    bandisky@ changing site settings to english i think it is not right. The plugin it will be right to work like before.

    dental1@ Yes – I think what is happening is that the (default – ‘events’) Slug is being translated into the local language for parts of the action – and this doesn’t work.

    Other parts are still using the original (‘events’) – and this does work.

    The solution is to use a Slug in the local language so it doesn’t get translated into anything else and everything should then work correctly.

    @jim5471 i tried your solution but it still does not work. I am forced to use NL language and in my case the slug is: evenementen. If i choose a list format: the url that i am getting is: /evenementen/(/?:list)/
    if i manually change the url to: /evenementen/list then it works.
    my solution for the moment is simple by using JS to change the urls to the correct format … until the plugins will fix it with an update

    @samueljclemens i tested this on your site and i get the same thing: the url is not correct. So if you want to see the list format use this link: https://www.volksschule-herbststrasse.at/events/list/
    or the day format:
    https://www.volksschule-herbststrasse.at/events/today

    Hi @bandisky – I switched my test site to NL and updated translations.
    The site wouldn’t switch list to month to day.
    Then I changed the Evenementen URL slug to evenementen and it all then worked.

    The url’s for each page were
    /evenementen/
    /evenementen/lijst/
    /evenementen/maand/
    /evenementen/vandaag/

    I haven’t seen anything like (/?:list) which looks like another translation query problem.

    Sorry but I don’t know what else to suggest.

    @jim5471 sounds interesting…which translations did you update? i looked in my /wp-content/languages/plugins/the-events-calendar-nl_NL.po and i saw that the translations for month and list are already there; only the day one is wrong.

    if you look at the href of the element… you will see a weird url like the one i gave you 🙂
    or maybe i am doing something wrong….i am curious to see which translation file was updated

    • This reply was modified 3 years, 9 months ago by bandisky.

    @bandisky When I switch languages I click the Updates menu item just under the Dashboard menu item.

    There should be a button at the bottom of the screen for Translation Updates.

    If there isn’t then to be sure click the ‘Check Again’ button. This is an important step as sometimes it takes two goes to get all the files.

    There are WordPress core translation files and Plugin translation files. It lists them as it updates.

    You could delete all language files from your \wp-content\language folder and update afresh.

    If you are cautious maybe rename the language folder and then update.

    @jim5471 thanks for the reply…i completely removed the languages folder did the updates ( before that everything was up to date ) and redid the updates…the issue is still present. Still the same weird links.

    @jim5471 i made a sandbox environment…and redid the steps you mentioned. it worked properly. So my culprit for the moment is now the theme itself: using avada theme for the moment. Thanks.

    @jim5471 I managed to find the issue after using a sandbox environment.
    i did the following steps:
    – changed events slug
    – checked all the language updates via WP Update tab
    – Checked permalinks (clicked save)
    I am using Post name based permalinks and by just clicking the save button the permalinks have been rewritten to the correct ones;

    @samueljclemens – can you please confirm this fix ?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Stuck on month’ is closed to new replies.