WordPress.org

Forums

[Plugin: Gigs Calendar] Stuck on Loading Screen (10 posts)

  1. Poppeseed
    Member
    Posted 7 years ago #

    I'm trying to set up the Gigs calendar but when I go to Manage > Gigs Calendar, it goes to a loading screen and attempts to load the settings (I assume). But it never finishes loading, as it hangs on that page. Any idea what is going on? It also happens with the Discography plugin.

  2. ckbip
    Member
    Posted 7 years ago #

    I was wondering the same thing about both

  3. DanCoulter
    Member
    Posted 7 years ago #

    What browser are you using?

  4. Bramus
    Member
    Posted 7 years ago #

    Had it too; when Firebug was enabled.
    It gets stuck right on the JS line "try{pageDestroy();}catch(e){};", but after pressing the play button (in Firebug) it continues normally..

    Temp Solution: disable Firebug for that domain ;)

    Might work fine if it's split onto multiple lines?

  5. Modesty
    Member
    Posted 7 years ago #

    Dan, I've been trying to install this plug in but I have no idea how to create the database tables manually... Please help!

  6. Modesty
    Member
    Posted 7 years ago #

    Ok, after 4 hours I have figured out how to create database tables manually, bur now I'm trying to Add new venue and when I clikck on the 'Add venue' button - nothing happens...

    Anybody?

  7. evanSK
    Member
    Posted 7 years ago #

    I had the same problem, when running localy on my windows, mashine (IIS 6.0, php 5.2.5, MySQL 5.0.51a), on Linux, it ran OK (interesting... mightbe some MySQL setting or what...)
    After some invetigation, I found a bug in the code. Problem was in INSERT mysql command, trying insert '' value into not null integer value, MYSQL then reported error:

    Incorrect integer value: '' for column 'private'

    I solved this problem for me, adding some code to gigs-classes.php:

    into the class venue:
    `var $_defaults = array('private' => 0,
    'apiID' => 0,
    'deleted' => 0); `

    into the class dtc_gigs_baseAR :

    function set_defaults(){
          foreach($this->_fields as $field){
            if(!isset($this->$field) && isset($this->_defaults[$field]))
              $this->$field = $this->_defaults[$field];
          }
        }

    and finally in dtc_gigs_baseAR->save() function I added:
    $this->set_defaults();
    after calling $this->pre_insert() function

  8. Citius
    Member
    Posted 7 years ago #

    Hi WordPress fans — I'm also stuck on the loading screen. I'm running Gigs Calendar 0.3.3 on WordPress 2.5.1. (I had previously tried to use Gigs Calendar with WordPress 2.3.3 with no success.)

    I was able to get Manage > Gigs Calendar to load once (a few days ago, when I reinstalled the plug-in after upgrading to WordPress 2.5.1) but never since.

    Since that time, I've modified my theme a little and installed another plugin (wordTube). In my technological ignorance, I've now tried deactivating all WordPress plug-ins and reactivating Gigs Calendar to see if that would help, but no dice.

    Disclaimer: I don't know PHP. (I'm pretty sure that's part of the problem...although once things get less hectic, I'll take a crack at my recently-purchased O'Reilly text). Therefore, I've been following the suggestions on this thread verbatim.

    To address the previous posts...
    ...by DanCoulter: I'm using Firefox.
    ...by Bramus: I don't use Firebug. (Also, for gigs-calendar.php, where would I split "try{pageDestroy();}catch(e){};" into multiple lines?)
    ...by evanSK: I tried inserting the code you suggested (though I'm not sure I did it exactly correctly). Now that I've cleaned up some syntax errors I made (involving a missing closing parenthesis), WordPress no longer tells me I have an error in my gigs-classes.php code...but I'm still stuck on that darn loading screen.

    Anyone have any idea why it might have worked that one time — and how I can relive that glorious moment forever? Your advice is appreciated. (Sorry for the long post, but I figured, the more details I provided, the better.) Thanks!

  9. DanCoulter
    Member
    Posted 7 years ago #

    @Citius

    Would you be willing to give me access to your blog so that I can see what it's doing on the backend? You can email me at "dan" at this plugin's domain.

  10. cbandas
    Member
    Posted 7 years ago #

    not working :(... what is the problems? i think what is my theme
    http://www.cbandas.com.ar/?p=265

  11. algal
    Member
    Posted 6 years ago #

    I'm seeing the same thing: the plugin installs fine, but then nothing loads on the Gigs Calendar page. I'm running WP 2.7, on Firefox 3.0.4, on Mac OS X 10.5.5. I'm on the default template and don't have any other plugins active.

    A shame! This sounds like the just the plugin my theatre troupe needs.

  12. DanCoulter
    Member
    Posted 6 years ago #

    algal,

    Would you be willing to send me a login to your site so that I can see what's wrong? My email address is my first name at my home page's domain

    http://dancoulter.com

Topic Closed

This topic has been closed to new replies.

About this Topic