Support » Plugin: WP Photo Sphere » Stuck on "Loading…"

  • Resolved Paddy Landau

    (@paddy-landau)


    Hello Jeremy,

    When I try to view an image, it sits stuck on “Loading…”

    My image is 4Mb with dimensions 5376px × 2688px, and is taken with the Ricoh Theta S camera. The photo sphere works properly on Google Photos (both Android app and desktop Chrome browser), so I know that the metadata must be OK.

    I tried a couple of different images (also around 4Mb, dimensions 5376px × 2688px), and even resizing one image much smaller to 740Kb, but I still have the problem.

    Interestingly, when I tried using your suggested sample image from Wikipedia, this worked. For comparison, this image is 2.8Mb with dimensions 7815px × 2936px.

    What can I do to diagnose and solve the issue with my photo spheres, please?

    https://wordpress.org/plugins/wp-photo-sphere/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Jeremy

    (@jeremy-heleine)

    Hello!

    To see if there is a precise error you can open the console of your browser (Ctrl + Shift + K on Firefox, or Ctrl + Shift + I on Chrome). If it doesn’t display an error, well… it’s sometimes hard to be web developer. 😀
    Is it possible for you to send me your panorama?

    Hi Jeremy.

    Thank you for looking at this.

    The only error (which I don’t understand) is:

    The deviceorientation event is deprecated on insecure origins, and support will be removed in the future. You should consider switching your application to a secure origin, such as HTTPS. See https://goo.gl/rStTGz for more details.

    I shall email you my website details and the panorama itself.

    Paddy,

    That warning is telling you that a future version of your browser will not allow a script to access a device’s orientation (i.e. compass readings) unless your site is delivered over HTTPS (which generally involves buying and installing an SSL certificate – something that your host could probably help with.) That isn’t related to your current issue, but it’s a good practice anyway.

    Thanks, Sean. Do you have any idea why that restriction is being put in place? (Buying an SSL certificate is a bit of a money-waste for me considering that it is a private, family-only website that will be password-protected.)

    Same issue here, from same camera. I’m still in the process of finding a solution, but in my case it appears to be related to caching and/or minifying of the javascript by Cloudflare or on CDN.

    Short version is works normally on uncached pages not running through Cloudflare or CDN but is stuck on loading for cached pages on the same site using exactly the same image file.

    Not sure if this is related to your case, but I mention it in case it offers a place to look.

    Sean: here’s an example: http://havecamerawilltravel.com/washington-photos/arlington-national-cemetery
    I suspect the culprit might be the CDN paths.

    Regarding the OP, interestingly, I have discovered that the problem occurs only on the desktop; the mobile device (Chrome on Android) works properly.

    Jérémy has found the problem and is working on a solution.

    In the meantime, an effective workaround is to use the attribute xml=”no” for the affected images.

    Has anyone resolved this i’m stuck on loading but do not see any errors in the error console. Does not display on mobile or Chrome or Safari.

    Plymouth

    Error I get if I try calling url image.
    Failed to load resource: Request header field Accept-Encoding is not allowed by Access-Control-Allow-Headers.

    I also have ssl on this domain. It does not make a difference. Someone mentioned xml statement. How do I use this?

    @techjase, I have just tried your link. It works on all of the following:

    • Desktop (Chromium on Linux)
    • Sony (Chrome on Android 5.1.1)
    • Nexus (Chrome on Android 6.0.1)
    • iPhone (Safari on iOS 9, I think)

    I don’t know where the problem might lie on your side.

    Thanks for your prompt reply. I did manage to fix it.

    I have had issues with loading as well no errors indicated. It would work with some image files but not all. Especially the ones the client just had shot specifically for this application. On a whim I opened the jpg image in GIMP and re-saved as a png and now it works. Not sure why this would matter but it did start working.

    Anyone have any thoughts?

    Plugin Author Jeremy

    (@jeremy-heleine)

    If it works when you re-save the image, then I think it’s an XMP-relative problem. Try disabling the “read XMP” option in the options page, or use the attribute xmp="no".

    Thanks, disabling did the trick.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Stuck on "Loading…"’ is closed to new replies.