Support » Plugin: Wordfence Security - Firewall & Malware Scan » Stuck in a “Optimize the Wordfence firewall” loop

  • Wordfence keeps giving me this notice:
    “To make your site as secure as possible, take a moment to optimize the Wordfence Web Application Firewall:”

    With the options of: “Click to configure” and “Dismiss”

    No matter how many times I try to configure it, or which configuration I choose, nothing works. The firewall never updates, and the notice reappears on page refresh every time.

    Disabled caching and other possibly conflicting plugins too — didn’t make a difference.

    Checked the user.ini file and saw the correct “auto_prepend_file” line, so not sure what’s going on.

    How can we get this resolved?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support wfdave

    (@wfdave)

    Hi @cmwir246,

    That notice is still continuing to show because the firewall isn’t being loaded.

    Can you answer these questions?

    – Is your site a multisite?
    – Have you tried using the .htaccess option instead of .user.ini
    – What hosting provider are you with? It’s possible that they overwrite auto_prepend_file.

    Dave

    Hey Dave,

    Appreciate the quick response.

    It’s a single domain with a single WordPress installation.

    I believe so, but it didn’t work when I tried. Any tips on that?

    Currently with A2hosting.

    Thanks!

    • This reply was modified 1 month, 3 weeks ago by  cmwir246.

    I am seeing the same thing on my a2hosted sites. Their support said they support .user.ini files but they also directed me to “php selector” options in cpanel but it does not list the auto_prepend_file setting.

    I am at loss how to fix it.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.