Support » Installing WordPress » stuck in a database-related loop

  • Resolved mizpat


    Yesterday I tried installing WP 3.4 on an AT&T hosting server, but kept getting a “can’t connect to database error.” During the third call to AT&T to troubleshoot the problem, AT&T discovered an error on their end. The DB server hostname localhost should have worked but didn’t because of their error.

    I got an email from AT&T this morning that they had fixed it, so I went to the install page again but got this message, with a Log In button following:

    “Already Installed
    “You appear to have already installed WordPress. To reinstall please clear your old database tables first.”


    However, since I personally never was able to complete the installation process, I never had a chance to enter a WP user name or password. Therefore, I cannot retrieve my password, since there is nothing to retrieve and no username associated with this site in the first place.

    I am a designer, not a database expert, and I’ve never used phpMyAdmin. I saw another recent post in this forum saying that he followed WP instructions for restoring and for optimizing the database, and it didn’t help (and possibly made things worse!), so I am leery of doing it that way.

    Plus, “clearing” the database doesn’t sound the same as “restoring” or “optimizing.” Maybe it’s a different process?

    Any help would be appreciated. I am under deadline.


Viewing 1 replies (of 1 total)
  • I did a search on “clearing the database” in the forums and found a clue that worked (along with checking the wp-config.php file, which AT&T had changed from localhost to their own hostname without telling me, even though yesterday they said that yes, localhost was correct. It wasn’t!).

    First I duplicated and downloaded AT&T’s wp-config.php file.

    Then I just needed to change the $table_prefix to something/anything else (e.g., from wp_ to wp1_), changed the file name back to wp-config.php, uploaded, and I was able to finish the installation and log in.

    Here’s the thread where I found the table_prefix clue:

Viewing 1 replies (of 1 total)
  • The topic ‘stuck in a database-related loop’ is closed to new replies.