Support » Plugin: All-in-One WP Migration » Stuck at “Done activating mu-plugins”

  • Resolved jimting7382

    (@jimting7382)


    Import process stuck at Done activating mu-plugins

    And now website showing The page cannot be displayed because an internal server error has occurred.

    Kindly advise for the solution. Thank you

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Yani Iliev

    (@yaniiliev)

    @jimting7382

    Enable WP_DEBUG then refresh the site.
    Usually, it happens when you are using a plugin or theme that is not compatible with the new PHP version.

    jimting7382

    (@jimting7382)

    I found this in wp-config.php:

    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the Codex.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define('WP_DEBUG', false);

    And I changed false > true

    But it doesn’t work

    Kindly adivse

    jimting7382

    (@jimting7382)

    I added code below then it works

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings 
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors',0);
    
    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define('SCRIPT_DEBUG', true);

    Thank you

    Plugin Author Yani Iliev

    (@yaniiliev)

    Awesome!

    Thanks really jimting7382. It looks like a miraculous solution to a problem that was chronic with me. You saved my day. Thanks so much…

    FYI for me it was the memory limit, trying to import a 1.2GB file, I added

    ini_set('memory_limit','512M');

    to the wp-config.php file and re-ran the import and it worked fine.

    @yaniiliev if you’re looking for plugin improvement ideas:

    1) Record the php memory limit in the export file, and alert the user that the memory limit is different on new host (e.g. same way it alerts you when going between PHP versions)

    2) Your script could continue to check memory_get_usage() and report to the user if the memory limit is getting close to all used up. At least the last error message before failing will be something useful like “You used 90% of PHP memory, try to increase PHP memory limit and try again”

    • This reply was modified 2 years, 7 months ago by dtbaker.
    Fetseun

    (@totaltrainingsystems)

    I am getting the same error. I am not very confortable in PHP. Is there any other way of correcting this error?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Stuck at “Done activating mu-plugins”’ is closed to new replies.