Support » Networking WordPress » Struggling with multisite

  • Resolved januitgever

    (@januitgever)


    Hello,

    I have activated the multisite option.
    Wordpress 3.0 is installed on a main domain on our VPS server.
    I choose for the virtual subdomain option during the installation of multisite. After creating a new site I tried to visit the new site.
    Then I get a page with the message “Apache is functioning normally”. When I try to go to the backend I get a 404 error.

    I searched this forum and found something about creating a wildcard subdomain record in the DNS settings.
    In DirectAdmin I created the A record:
    *.domain.nl with the ip-address of our vps server.

    This did not resolve the issue.
    I appreciate if someone can help me.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You need a wildcard record in Apache.

    In the vhost entry for that web account, find where it says this:

    ServerAlias yourdomain.com

    Add this:

    ServerAlias yourdomain.com *.yourdomain.com

    Hi,

    It works now! With such a simple line of code!
    Thanks for you help.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Struggling with multisite’ is closed to new replies.