Support » Plugin: AMP for WP - Accelerated Mobile Pages » Struggle to show AMP version Home page

  • Hi .
    The plugin works well on my website excepted on the home page.
    My home page is a static page that I have asked wordpress to use.

    I have created a AMP version in the WP editor, and I do have checked the the case ( Use This Content as AMP Content) .
    But still , it does not use this AMP version. It use the “regular” version.

    Is it normal? How can I deal with that?
    my website adress : https://www.wedding-photography-minneapolis.com/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Hey @frenchtouch

    Thank you so much for using the plugin!

    You can setup a Special frontpage for AMP from Dashboard > AMP > Frontpage options, turn it on and select the frontpage to display in the homepage. That should do that trick.

    I hope it helps,

    If you have any questions, feel free to ask.

    It do works, but is shows the “regular” page in AMP.
    If I turn on the check boxe “Use This Content as AMP Content” , then It shows nothing… => How can a I display a specific AMP content on the home page?

    I have that problem as well.

    This is with the latest update to the plugin.

    If you tick “Use This Content as AMP Content”, nothing then shows up on the front page itself. All content is removed and there is just an empty tag:

    <div class="amp-wp-content the_content"> 
    	</div>

    It works on all other Pages, but not the Front Page (is_front_page()) or Blog Page (is_home())

    oh 🙁 .

    Did you find any solution ?

    Same issue here!

    A quick dirty solution that may not apply to everyone:

    Cut the HTML from the AMP editor on the affected page that is showing blank, uncheck the ‘Use this as AMP content’ and paste it in a separate new page like “Home-amp” in the standard html editor (not the amp html editor). Select that newly created page in the AMP setting: ‘Select Page as Front Page’.

    Worked for me but definitely looking for a permanent solution as well.

    @mikepatrickjohnston
    I was thinking to the same. But … It will confuse google !

    If you really wanted to, you could disallow the temporary AMP homepage slug from being crawled in robots.txt possibly.

    hmmm …. Hmmmm…..I am not sure of witch solution would prefer Google.
    That a website have 2 home page, or that AMP send to a non index webpage….

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Hey Guys @frenchtouch @mikepatrickjohnston @clicknathan

    We really apologize for the inconvenience. We were already aware of this issue and it has been already fixed. Please see this ticket: https://github.com/ahmedkaludi/accelerated-mobile-pages/issues/604/

    This will be pushed on Saturday on 4th March, when we release this update, the issue will be fixed automatically for you guys and everyone.

    Thank you so much for helping us!

    Regards,
    Ahmed

    As noted over on GitHub, this doesn’t appear to be fixed completely…

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Hi Nathan @clicknathan

    This fix has not been released yet. it will be released in the next update on Saturday.

    The latest version does not have this code yet. It will be included in the next update.

    Are you checking the beta version?

    Just wanted to report back here that this has not been fixed. Here’s how we’re trying to set this up:

    1. Turn on “AMP on Pages” in General tab of settings.
    2. There are options on the Homepage tab of AMP settings:
    A. Homepage Support
    B. Front Page
    C. Select Page as Frontpage

    If you do any of these, though, the /blog/ (or whatever page you have set for your latest posts) also get the homepage content.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Struggle to show AMP version Home page’ is closed to new replies.