Support » Plugin: Yoast SEO » Structured Data Not Including Articles or Amp Article markup on Web Stories

  • Resolved mattatnicolebarkerva

    (@mattatnicolebarkerva)


    Hi. I’ve been having this issue for a while now. My Google Web Stories made by the standard Web Stories plugin are validating as AMP articles (good). When I check further into their structured data I see valid markup for
    * Breadcrumbs
    * Sitelinks Searchbox

    I am expecting to see markup for Articles and AMP Articles as well but they are not in the code. I’ve checked my Yoast settings many times and have my Web Stories content types set to:

    Default Page Type = Web Page
    Default Article Type = Article

    My other sites have extremely similar configurations and show the “Articles” and “AMP Article” markup. I have tried disabling all of my plugins to see if it is a conflict and that didn’t change my results.

    Can anyone help me figure out why this added markup is not being included on my Web Stories?

    I’m using Yoast 15.9.1 on WordPress 5.5.1.

    Thanks in advance!

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Michael Tina

    (@mikes41720)

    Hi @mattatnicolebarkerva

    We understand that you aren’t seeing the ‘article’ schema output for your web stories.

    First of all, it looks like your WordPress and Yoast SEO plugin are both outdated. Would it be possible for you to first update to the latest version of WordPress 5.8.2 and Yoast SEO 17.7.1 and see if this solves the issue?

    If updating doesn’t solve the issue, could you please check if you’ve configured the settings in this article (especially step 1 and 2) – https://yoast.com/help/implementing-schema-with-yoast-seo/#what-you-need-to-do

    Thread Starter mattatnicolebarkerva

    (@mattatnicolebarkerva)

    Thank you Michael. My Yoast plugin is fully updated, but I’m guessing that because WordPress is out of date that the latest version of Yoast is not available / compatible so 15.9.1 is the only one I can use. I’m guessing the WordPress update is fairly risky and I don’t want to make a change that large in December which is my highest traffic month.

    I will research and update things as soon as I can. I’ll respond back if that fixes it.

    Thanks again for the response.

    Matt

    Thread Starter mattatnicolebarkerva

    (@mattatnicolebarkerva)

    Hi Michael (and community),

    I updated the site to the latest WordPress and Yoast versions. I am still having no luck getting that schema to appear.

    The schema does show breadcrumbs and sitelinks searchbox, but nothing for Articles or Amp Articles. I have double checked all of my configuration against the article you linked me to. Any other thoughts on what is going on here?

    https://search.google.com/test/rich-results/result?id=LmQx1C6AR1aKgDtP9_7YYg

    Thanks ahead of time.

    Plugin Support Suwash

    (@suascat_wp)

    @mattatnicolebarkerva

    Could you please go to SEO > Search Appearance >> General(tab) and make sure you’ve specified the Organization Name and Logo? Once you have that I expect the missing schemas to show up.

    Please note you might need to run SEO Data Optimization if not already from the SEO >Tools page.

    Thread Starter mattatnicolebarkerva

    (@mattatnicolebarkerva)

    Suwash,

    I can’t believe it. I had an outdated logo file selected I guess for my organization settings and so it was showing as a broken image? Not sure how that was possible, but I updated the logo and all structured data now exists. Thank you very much for your help!

    Matt

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Structured Data Not Including Articles or Amp Article markup on Web Stories’ is closed to new replies.