Support » Plugin: iThemes Security (formerly Better WP Security) » (Strong) Password Requirements feature not working – new password not stored

  • dougjoseph

    (@dougjoseph)



    I’m on iThemes Security version 7.0.2.

    The new “Password Requirements module” for managing and enforcing password requirements…

    …is not working correctly for me.

    I went to login as Admin, was told my password was not strong enough. I entered a strong password and submitted it. I was not logged and the new password was not successfully set in my account.

    Instead, I was taken to a URL that showed me the home page, with (in the URL) a reference to password process (may have been a query string value, did not pay close enough attention). Efforts to login using the new password failed, and efforts to login with the old password resulted in my being told my old password was not strong enough, and thus repeating the whole cycle again.

    In order to get logged in, I had to disable the iThemes Security plugin (using FTP to move the folder to a “plugins-disabled” folder). Then, I was able to log in using the OLD password. Clearly, the intended process of storing the new, strong password, is failing somehow.

    Currently I have the new module switched off.

    Thanks in advance if anyone knows what I can do to get it working.

    PS: I know there is a 7.0.3 update, but its Changelog does not indicate it has awareness of or a fix for this issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • the same issue is happening on my wife’s site as well.

    Same here too. Been using this for years and sad that they broke things like this. Disabled plugin and will find another.

    This is still an issue.

    The recently added “Password Requirements” module does not work. It’s locking admins out of their sites. It demands a strong password, and when one is supplied, it does not save the new password, and an endless of loop of demanding a new password ensues. The only way to get back into the dashboard is for the admin to disable the plugin and then (if desiring to continue using the plugin) re-enabling it after logging in, and turning off the “Password Requirements” feature.

    Happening to me as well

    wegosi

    (@wegosi)

    confirmed.
    it’s not working.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.