WordPress.org

Forums

Forever
[resolved] strippping tags (18 posts)

  1. cmarkham
    Member
    Posted 1 year ago #

    On the home page it doesn't allow me to have bullets in a post. When I inspect the source the ul and li tags are gone. Where in the theme's code is it stripping the tags so I can have the bullets show up? Thank you.

  2. Could you please provide a link to your site so I can take a look?

  3. cmarkham
    Member
    Posted 1 year ago #

    Well I was able to stop the stripping today but it caused another problem from the change in the function, but it worked to my advantage. So there is probably a better way to do it than I did.
    But here is an alternative fix to stop the stripping and fix the problem it caused after. This will only work for FOREVER THEME.
    On line 58 in recent-posts I changed it to this...

    <div class="recent-summary">
    				<?php get_template_part( 'content', 'single'); ?>
    			</div><!-- .recent-summary -->'
    If you have done it right, the tag stripping should have stopped and it should have caused the post to double up the title. I didn't know how to change this within the function so I went to the CSS to fix it and added this...
    .recent-header {
    left: -9999px;
    position: absolute;
    top: -9999px;
    }`
    It was kind of cool cause the doubled up titles where 2 different classes. One was .recent-header (permalink to post) and the other was .entry-header (static title) and I wanted to stop the post from linking and just have it static. If you wanted to keep the title linking to the full post, just switch out my example with .entry-header. I put it in the Latest Post section in the CSS but you really could just put in anywhere. Hope this helps anybody.

  4. Hi there, the theme definitely shouldn't be stripping bullets from posts on the homepage. I just did a test with a clean version of Forever and WordPress 3.6, and I see bullets on the homepage just fine, as you can see in this screenshot:

    http://cl.ly/image/3A3Y1J310e2J

    I'm glad you found a workaround, but if you'd like to troubleshoot this further, you might try:

    - deactivating all your plugins temporarily. If the problem goes away, reactivate them one by one to find the culprit.
    - disabling your child theme temporarily.

    Good luck.

  5. cmarkham
    Member
    Posted 1 year ago #

    That is odd, I have WordPress 3.6 and the Theme version is 1.2.1. I switched to the non-child version and disabled all my plugins and they still weren't showing up. Not sure what would be causing that if you were able to get it to work. I never edited the original theme's code.

  6. cmarkham
    Member
    Posted 1 year ago #

    Ya know what, I may not have mentioned it before but the problem is on the post/home page as a 'standard' sticky post. Were you trying it on the single post page? The image was too small to tell.

  7. Hmm - my screenshot was from the homepage, which is set to display latest posts - not a single post. I tried setting the post to sticky but the bullets are still there. It's a standard post format.

    Is it possible for me to take a look at your site if it's online?

    Is it the same thing if you use a different browser?

  8. cmarkham
    Member
    Posted 1 year ago #

    Sure here it is with the plugins deactivated in the original theme with no code edited. The 'Simple to use' post is the one being stripped on the home page, then when you click on the post, all the tags are on the single page post.
    http://luxbelle.atticdev.ist.unomaha.edu/

  9. Thanks for the link! I'm seeing bullets on the homepage on that post:

    http://cl.ly/image/3v3I1u1n0q0W

    They're there in the browser source as well:

    <ul>
    <li>Arrives fully assembled.</li>
    <li>Needs no plumbing.</li>
    <li>Plugs into standard 110 outlet.</li>
    <li>Fits in most rooms.</li>
    <li>Offers low maintenance.</li>
    </ul>

    What browser and version are you using?

    Could you try turning off all your browser extensions? I wonder if something is interfering. You could also try looking at your site in a different browser. Let me know what you see.

  10. cmarkham
    Member
    Posted 1 year ago #

    Sorry but you must have looked at it when I turned my child theme back on, because in your screenshot it doesn't show the date of the post and that was part of my modified child theme. I have it turned off again for now and I did try it in firefox, chrome, and safari and they are still stripping for the original theme. If the background is a wood image and doesn't show post dates, then that is the modified child theme. With the dates, it is the original.

  11. I've believe figured out what the problem is. :-)

    The version of Forever that I've been testing with was downloaded from WordPress.org, while the one you've been using is the slightly different version from WordPress.com.

    Now that I've tested the WP.com version I see the bullets being stripped out, just as you do. I will report this to the theme developers, but in the meantime, you can try downloading the version here, which should work as expected:

    http://wordpress.org/themes/forever

  12. On second look, I think both versions of the theme strip the bullet formatting. When I tested earlier, I hadn't checked off the option under Appearance > Theme Options, which displayed four recent posts on the homepage.

    I am going to inquire with the theme developers and I'll keep you posted here.

  13. In the end, this is an issue caused by the fact that in WordPress, HTML tags are stripped from post excerpts, which is what that theme is displaying when you choose the "Show four of your latest posts in columns on your home page." option. This in all themes, not just Forever.

    To preserve the HTML in post excerpts, the simplest solution would be to use a plugin like Advanced Excerpt. I just tested it, and the bullets are preserved:

    http://wordpress.org/plugins/advanced-excerpt/

    Let me know how it goes.

  14. cmarkham
    Member
    Posted 1 year ago #

    I think it is done on purpose for some themes, but I have never really looked into why. That would be great if they were able to tell us how to stop it correctly.

  15. It's a feature of WordPress core.

  16. Here's a reference about how the default excerpt feature works in the WordPress core:

    http://codex.wordpress.org/Function_Reference/the_excerpt

    Also in the latter case, HTML tags and graphics are stripped from the excerpt's content.

    You could try using the Custom Excerpt field to preserve the HTML formatting, if for some reason you don't want to use the plugin. I just tried it and it seems to work:

    http://cl.ly/image/342z1J0h1G0f

    http://cl.ly/image/3p0J0E3q1r3J

    If you don't see the Custom Menu block, you can activate it under Screen Options:

    http://cl.ly/image/3T2K0y1X3A0u

  17. cmarkham
    Member
    Posted 1 year ago #

    That worked. Gezz that was so dang simple. Thanks a bunch!

  18. You're welcome. We got there in the end. :-)

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags