Support » Plugin: WooCommerce Stripe Payment Gateway » Stripe’s latest API – Webhook Failing!

  • Resolved kaotik

    (@kaotik)


    Stripe recently upgraded the API again this past week and now the latest version of WooCommerce Stripe does NOT work with Stripe’s latest API 8-14-2019. Getting constant failed webhooks!

    Constant “400 (Bad Request)” errors.

    Is there an update in the works for this?

    • This topic was modified 2 years, 12 months ago by kaotik.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter kaotik

    (@kaotik)

    Update: I removed only the Webhook Secret from the WooCommerce > Stripe settings and the Failed event types stopped and everything has now resumed to Succeeded event types in Stripe. So what’s causing that to happen with the Webhook Secret?

    All WooCommerce and Stripe plugins are up to date on our WordPress site so I can’t understand why this started happening out of the blue. This all began after the latest Stripe API upgrade.

    Plugin Support melinda a11n

    (@melindahelt)

    Automattic Happiness Engineer

    Can you please check your server’s clock – a quick way to do so is to go to wp-admin > Settings > General > Timezone and see what time it thinks it is

    Let me know if the server clock matches the same local time that you have in the site.

    Thread Starter kaotik

    (@kaotik)

    Thanks for your reply Melinda. I’m not sure I understand what you mean by if it matches the same local time that’s in the site. Here’s what I have at the time of looking this up…

    Chicago (CST)
    Choose either a city in the same timezone as you or a UTC timezone offset.

    Universal time (UTC) is 2019-08-23 01:18:53. Local time is 2019-08-22 20:18:53.

    This timezone is currently in daylight saving time.
    Standard time begins on: November 3, 2019 2:00 am.

    Preview: 8:18 pm

    • This reply was modified 2 years, 12 months ago by kaotik.
    Plugin Support Doug – a11n

    (@dougaitken)

    Automattic Happiness Engineer

    Hey @kaotik

    Looks like this one slipped through without a reply – are you still having issues or has this been resolved in the meantime?

    Thanks,

    Thread Starter kaotik

    (@kaotik)

    @dougaitken thanks for the follow up. I actually ended up removing the webhook secret on the WooCommerce side of things and haven’t received any errors since. It seemed to be conflicting with Gravity Forms webhooks that I also use for Stripe. WooCommerce is still working without the use of that webhook, which was the only way to get it working.

    I noticed there were some updates for this plugin recently, which I did update and I can try to re-apply the webhook secret again in the coming days to see if it works.

    Plugin Support Doug – a11n

    (@dougaitken)

    Automattic Happiness Engineer

    Hi @kaotik

    How odd – if everything has been working as expected, that is great! But please do keep us posted with how things go in future.

    I will mark this thread as Resolved for now, but please do open a new one if you need any more help!

    Thanks,

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Stripe’s latest API – Webhook Failing!’ is closed to new replies.