Support » Plugin: WooCommerce Stripe Payment Gateway » stripe webhook errors

  • Resolved tgunergun

    (@tgunergun)


    Hi there,

    Are there any changes regarding webhooks with woocommerce 4.1 update could be affecting your plug-in?

    Asking hence i have been getting webhook errors (http status code: 400 (bad request) since 14th May.

    Thanks
    Tunc

Viewing 12 replies - 16 through 27 (of 27 total)
  • Thread Starter tgunergun

    (@tgunergun)

    @dougaitken In my scenario, stripe plug-in as well as stripe.com are both in Live mode, that’s when/where i experience this problem. Would you be available for a zoom session for further troubleshooting next week? Thanks

    Plugin Support Doug – a11n

    (@dougaitken)

    Automattic Happiness Engineer

    Hey @tgunergun

    We’re not able to offer Zoom sessions – our support is available via the forum or via WooCommerce.com.

    I can confirm though that if my site is in live mode then all webhook events are successful on my Stripe.com account in live mode – both initial attempts and resending those. Here is a screenshot from account showing the one failure – this was when I was testing a resend when my site payment gateway settings were in test mode.

    https://d.pr/i/U95oqD

    This brings up back to being unable to replicate this across the board – something is rejecting your webhook delivery if there is a webhook signature added.

    The only mention I could find on our GitHub repository was related to a time/date error – https://github.com/woocommerce/woocommerce-gateway-stripe/issues?q=is%3Aissue+signature+

    Can you check to see if that resolves it at all? If not, then I’m struggling to find the culprit here and more debug logging may need to be enabled on your site to narrow down the cause.

    Thanks,

    Thanks,

    Thread Starter tgunergun

    (@tgunergun)

    @dougaitken Solved the problem by changing time zone settings on https://dashboard.stripe.com/settings/account. Not sure how that changed from EU/London to UTC-1. but it’s solved now. My Date/Time/Timezone settings are correct on WP side.

    Thanks
    Tunc

    Plugin Support Doug – a11n

    (@dougaitken)

    Automattic Happiness Engineer

    Hey @tgunergun

    AH! That is fantastic to hear, thanks so much for letting me know that fixed your issue!

    I’ll mark this as Resolved for now and add it as a note on other threads with a similar scenario.

    Thanks,

    I’m afraid this did not resolve the issue for us. Our timezones were already correct (London).
    Unless there is some BST discrepancy between WP and Stripe?

    Thread Starter tgunergun

    (@tgunergun)

    @dougaitken

    add in to your documentation… so people know that WP and Stripe must have time synced (inc. correct time zone). cheers Tunc

    my problem was thinking Live Secret Key and Webhook Secret were same thing…

    Hi @dougaitken.

    Sorry to resurrect a slightly older post, but I’m having exactly the same issue. I’ve checked the timezones and they are both correct (London). Also deleted from CleanTalk. All my webhooks are failing with HTTP status code 400 (Bad Request). I’ve triple checked all my keys too.

    But if I delete the webhook secret from Woocommerce, then the webhoks start working again.

    Any thoughts of what else to try please? The site is only 1 week old and the webhooks have been failing since launch.

    Hi @dougaitken we have also got a client where this manifested in the exact same way – and I can confirm that removing the webhook signing secret in WooCommerce settings and saving allowed to send the webhook from Stripe.

    Literally doing only those two actions, in quick succession

    1) Remove signing secret and save in plugin’s WooCommerce settings; and then in another tab
    2) At Stripe, in Webhooks, find a recently failed attempt and click “resend”

    This was successful.

    Note, we have many clients using Stripe where none of this applies. There’s two on the same setup where this is happening. Trying to find the root cause. Note we can assist with a debug on this @dougaitken – hit me on WC Slack or we can raise or add to a GitHub ticket. Posting here in case anyone has this issue in mean time and wants to quick fix.

    Just an update here – when the API is updated in Stripe, Stripe expires your webhook secret – in Stripe. You have saved this in WooCommerce settings. The solution is to:

    1) Go to Stripe > Developers > Webhooks and select the webhook you’ve setup for this store’s WooCommerce endpoint; and
    2) Click “click to reveal” on the signing secret – copy this value; then
    3) In WooCommerce > Settings > Payments > Stripe remove the “Webhook Secret” value you have saved (this was the “old” value – but it is not visible)
    4) Paste the value you collected from Stripe in and hit “Save”

    5) To test, back in Stripe, hit “resend” next to a failed webhook connection listed under “Webhook attempts” – assuming it is working, you’ll see “resending” and then the attempt you just resent will be successful.

    Removing the Webhook Secret from Woocommerce settings also worked for me.

    Anshul

    (@anshulbijoux)

    Thanks rgroves (@rgroves)

    “Removing the Webhook Secret from Woocommerce settings also worked for me”

    Worked for me as well.

Viewing 12 replies - 16 through 27 (of 27 total)
  • You must be logged in to reply to this topic.