Support » Plugin: WooCommerce Stripe Payment Gateway » Stripe ver. 4.1.5.: it does not recognize SSL site certificate

  • Resolved milosmili123

    (@milosmili123)



    Stripe ver. 4.1.5.: it does not recognize SSL site certificate

    Updated to ver. 4.1.5. today (May 29 2018) and get this: “Stripe is enabled, but a SSL certificate is not detected. Your checkout may not be secure! Please ensure your server has a valid SSL certificate – Stripe will only work in test mode”.

    There is nothing wrong with my site SSL cert, still valid.

    Please advise. Thx.

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author royho

    (@royho)

    Its only a notice. If you confirm you do indeed have working SSL. You can dismiss that warning notice.

    Raul

    (@skillswimming)

    Hi, I have the same notice after upgrading stripe, I have a SSl installed, and when my costumers pay with stripe they are getting failed orders.

    • This reply was modified 5 months, 3 weeks ago by  Raul.
    Plugin Author royho

    (@royho)

    @skillswimming Please start your own thread with all details. SSL and failed orders are not related.

    Same issue here. V 4.1.5 suddenly shows this message. Good SSL conformed via https://www.ssllabs.com.

    How sure are you that payments will still work in non-test mode? The warning is ominous, “Stripe will only work in test mode” sounds like no payments will be processed.

    Same warning messages:

    Stripe is enabled, but a SSL certificate is not detected. Your checkout may not be secure! Please ensure your server has a valid SSL certificate - Stripe will only work in test mode.

    Your store does not appear to be using a secure connection. We highly recommend serving your entire website over an HTTPS connection to help keep customer data secure. Learn more here.

    I checked with my hosting company, who also installed my SSL certificate; they said it is installed.

    Thank you for your time; please advise.

    Bill

    More data:

    We are using the WooCommerce Force SSL setting, wondering if that’s a factor. It was working before, but after upgrading WooCommerce Stripe Gateway gives this error and WooCommerce itself gives another warning about no SSL.

    I’ve verified that the store does load as SSL.

    I have the same error messages as above since doing the updates. I have already lost a sale because of this!!! Stripe is aware of the issue as I just raised a ticket with them

    Plugin Author royho

    (@royho)

    @livruff that is incorrect. This is just a notice. It doesn’t affect if payments work or not.

    @milosmili123 Unchecking and checking it did not resolve this for me. Messages still appear.

    Unchecking and checking the box didn’t work for me either. And it doesn’t appear to be just a notice. It clearly says it will not work “Stripe is enabled, but a SSL certificate is not detected. Your checkout may not be secure! Please ensure your server has a valid SSL certificate – Stripe will only work in test mode.”

    SSL certificate is perfectly installed so there should be no issue.

    If this is just a notice the wording should be changed. I haven’t had any sales the last few days but this might actually be the reason!

    What is going on?

    I think Royho is correct in that just because we’re seeing the message, that doesn’t mean SSL isn’t working. It appears that customers can make purchases on my site, even though I’m getting warnings from both the Stripe plugin and WooCommerce. The fact that the warning is also coming to me from WooCommerce tells me this may be a WooCommerce bug, and Stripe is simply a victim of this until it’s fixed.

    Plugin Support dougaitken

    (@dougaitken)

    Automattic Happiness Engineer

    Hi @milosmili123 @skillswimming @kcren @livruff @martijndieleman @notsteve

    Can you check on your WooCommerce system status and let me know if the SSL is showing a ✔️ there?

    Secondly, please head to your general WordPress settings page, Settings > General and see if WordPress Address (URL) and Site Address (URL) both show https:// there like this http://cld.wthms.co/OVBMQr

    Are any of you using plugins which handle the SSL?

    Thanks,

    Hi @dougaitken

    My system status shows no tick on SSL and says YOUR STORE IS NOT USING HTTPS even though I do have a SSL certificate. My settings also shows my URL addresses as http instead of https. I dont understand why this has all changed seemingly since the update I done. My Stripe payments seem to be working now though

    I also have this warning. It works, but the message says it’s in test mode, so I’am not confortable with this.
    The woocomerce status says SSL is not active, althought it is.
    I am using latest version of both plugin.

    Plugin Support dougaitken

    (@dougaitken)

    Automattic Happiness Engineer

    Hi @livruff

    > My settings also shows my URL addresses as http instead of https.

    This isn’t Stripe related but more about the WooCommerce extension.

    Can you update your General Settings to show https:// – if the field isn’t editable, then please ask you host about how to update that.

    Hi @contremaitre – can you check about the general settings fields I mentioned previously.

    In general, we have a fix for the SSL error coming in the next release of the extension that should remove this problem.

    However, if your General Settings are still http:/ the general WooCommerce System Status will still show the warning.

    Thanks,

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.