Support » Plugin: Simple Membership » Stripe Payment Declined – Member Still Got Access

  • A stripe payment declined due to ‘insufficient funds’, but the subscriber still got access to the protected content. Is there any way I can avoid this in the future?

    TIA!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi, this is the first time I hear of something like this. I have submitted a message to the developers to investigate further your issue.

    Thank you

    Plugin Author wp.insider

    (@wpinsider-1)

    Looks like the webhook is not being received by the plugin on the site from your Stripe account. This will need some debugging to make sure everything is connected and setup correctly on your site. Enable the debug log feature of the plugin so you can see if the webhooks are being received by the plugin:
    https://simple-membership-plugin.com/enable-debug-logging/

    If you go to the “Webhooks” menu inside your Stripe account, do you see webhooks configured according to what the documentation says?
    https://simple-membership-plugin.com/sca-compliant-stripe-subscription-button/

    Hi, thanks for the help.

    I have checked the webhooks and everything appears to be configured correctly.

    Debug is also enabled.

    When I investigate the subscription in question, it says charge failed (insufficient funds, but further down the webhook attempt succeeded.

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, is your issue resolved?

    lipsticklifters

    (@lipsticklifters)

    Hello,

    I don’t think so, but I haven’t had any other declined payments to be sure. In this case I manually deactivated the account. Will keep an eye out to see if it happens again.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.