WordPress.org

Forums

WP-Invoice - Web Invoice and Billing
Stripe not working. (11 posts)

  1. ajaxouch
    Member
    Posted 1 year ago #

    I'm not sure if this is a problem with WP-Invoice or my settings on stripes website.

    I set up my stripe account before I set up my ssl, worked great.
    Not sure if this is what caused the problem, but then I set up my ssl, and my website's ip address changed.

    Now stripe payments get an error saying, "Service unavailable at this time, please try again later." With no record on my stripe account of any process trying to happen.

    I tried to see if I could change my website settings, but it seems uneditable through my dashboard on stripe.com

    I am currently also waiting correspondence from stripe support as I could not find this error response in their list of errors.

    https://wordpress.org/plugins/wp-invoice/

  2. ajaxouch
    Member
    Posted 1 year ago #

    On my stripe logs, I can see the tokens, but no charges went though. POST body doesn't seem to be parsed, just empty in the log.

    Got everything in test mode on my wp and my stripe account, created a new invoice, still getting this weird unavailable error.

  3. Anton Korotkoff
    WP-Invoice Support
    Plugin Contributor

    Posted 1 year ago #

    Hey,

    it works without ssl as I tested. I need to do some tests with ssl. I'll let you know.

    Thanks.

  4. Anton Korotkoff
    WP-Invoice Support
    Plugin Contributor

    Posted 1 year ago #

    ajaxouch,

    I was not able to replicate the issue even with SSL activated.
    Actually this error appears if Stripe library that does payment stuff can't do a request to third-party service. Please check that (curl, fopen) etc.

    Thanks.

  5. ajaxouch
    Member
    Posted 1 year ago #

    Stripe says:
    "Service is unavailable. Please try again later." is not actually an error that comes from our API. This looks like an error that is occurring in your integration separately from Stripe. Looking at your logs[0], I do see that all tokens are being created successfully. Since we are not receiving any API requests after the tokens are created, this looks to be an error specific to the attempt to turn the token into a charge. This is something that you (or your developer) will need to debug on your end as it is an error that is actually happening in your specific integration, not in Stripe.

  6. ajaxouch
    Member
    Posted 1 year ago #

    Anton, I have a test account set up if you'd like to log in and see if you can pinpoint that issue. But it's sounding like it might be some sort of conflict?

  7. ajaxouch
    Member
    Posted 1 year ago #

    As far as plugin conflicts, I thought it might be sharethis, or speed booster pack ( which I don't use anymore ) Speed booster pack changed my site to use googles jquery library, not sure if that would be the issue.

  8. ajaxouch
    Member
    Posted 1 year ago #

    It is a plugin conflict, let me deduce which one.

  9. ajaxouch
    Member
    Posted 1 year ago #

    Appears to be with SP client document manager.

  10. ajaxouch
    Member
    Posted 1 year ago #

    Maybe something to do with the way both plugins access/save user ids with files?

  11. Anton Korotkoff
    WP-Invoice Support
    Plugin Contributor

    Posted 1 year ago #

    Sorry, not sure I understand what you do. Do you have some plugin that conflicts with WP-Invoice?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP-Invoice - Web Invoice and Billing
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic