Support » Plugin: WooCommerce Stripe Payment Gateway » Stripe Not Visible at checkout

  • Resolved supportmm

    (@supportmm)


    Hello,

    We are currently experiencing problems with our Stripe Plugin. The Stripe option (card/credit card) is not visible at checkout. Running the latest Stripe version (4.5.5) with the latest woocommerce (4.7.1) and WordPress (5.5.3).

    I can confirm that the Configuration of Stripe is correctly set. The domain has been verified correctly which can be seen in the logs and Stripe Dashboard. When looking at the logs it keeps displaying these entries:

    2020-11-25T12:29:14+00:00 DEBUG
    ====Stripe Version: 4.5.5====
    ====Start Log====
    Stripe Payment Request live mode requires SSL.
    ====End Log====

    We already have SSL installed using lets encrypt. the woocommerce and wordpress install is defined correctly using https in the settings (have already read some previous threads about the issue). Have also called the Hosting provider and they can confirm the certificate is working correctly and is setup correctly. Our other payment providers Klarna, Swish and Bambora are working as expected without any issue.

    Any clue of what the issue might be?

    Here is a link to our site:
    https://minimotorssverige.se/

    • This topic was modified 2 months ago by supportmm.
    • This topic was modified 2 months ago by supportmm.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support tijosh

    (@tijosh)

    Hi there @supportmm,

    Most of the time when a payment method is not showing at checkout, it’s due to a plugin or theme conflict. The best way to test that is to deactivate all plugins besides WooCommerce + Stripe and activate a default theme like Storefront, then check for the problem. We’d suggest doing these conflict tests on a staging site (which is a copy of the live site). If the hosting company provides staging as a feature, that is a great place to start. If not, you can use the WP Staging plugin to create the staging site. We have a guide on conflict testing here.

    If the problem persists with only those two plugins active and a default theme active on a staging site, please open a ticket for Stripe from your WooCommerce.com account so we can take a closer look. Please create an admin user for us following this guide.

    Plugin Support AW

    (@slash1andy)

    Automattic Happiness Engineer

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.