WordPress.org

Forums

s2Member Framework (Member Roles, Capabilities, Membership, PayPal Members)
[resolved] Stripe Multi Shortcode Issue (5 posts)

  1. bazchas
    Member
    Posted 1 year ago #

    Hey Guys,

    Thanks very much for the latest update with Stripe, it works wonderfully and am over the moon to be rid of all our PayPal issues.

    However, I think I may have spotted a small bug with the multiple shortcode functionality which I have been using with the PayPal and AuthNet pro forms without issue.

    It seems that the s2p-option variable is not set for Stripe forms upon refresh. The result of which is that upon selection of the checkout option the page refreshes but reverts back to the first option on the list. Leaving no way to select the other options.

    I've tested with the vanilla multi shortcode examples you give in the help docs and can confirm that these produce the same issue. I've also tried setting the option manually which works fine so it is being picked up OK, just not set on refresh.

    If you need any further information let me know.

    Cheers.

    https://wordpress.org/plugins/s2member/

  2. bazchas
    Member
    Posted 1 year ago #

    Hi Guys,

    Sorry to bump but can I get a response on this please as we need this functionality to go live and as things stand we have no way to implement the multi form functionality.

    Many Thanks.

  3. JasWSInc
    Member
    Plugin Author

    Posted 1 year ago #

    Hi :-) Thanks for the report! I'm moving this over to our issue tracker so that one of us can take a closer look at this before the next release. Please see: https://github.com/websharks/s2member/issues/296 If you have any additional details you'd like to add, please do that at GitHub.

    In the future please file bugs related to the pro version of s2Member via this wizard. Bugs are ultimately tracked at GitHub. Thanks!
    https://www.websharks-inc.com/support/?product=s2member&request_type=bug_report

  4. bazchas
    Member
    Posted 1 year ago #

    Brilliant, thanks very much Jason.

    I've bookmarked the support link now so will be sure to use that in future.

    Will update if I have anymore relevant information.

    Thanks again!

  5. bazchas
    Member
    Posted 1 year ago #

    Hi Jason,

    Just wanted to say a big thank you for getting this issue fixed so quickly.

    Have just tested and all working brilliantly.

    Many thanks for all the hard work!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic