Support » Plugin: WooCommerce Stripe Payment Gateway » Stripe form not showing

  • Resolved sergioh4l

    (@sergioh4l)


    Hello,

    I just realized that the Stripe form doesn’t show up at checkout. The only change I’ve made recently has been to change the hosting, apart from upgrading to WordPress 5.0.3 and the rest of the plugins.

    What should I do to show it again?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Phil

    (@fullysupportedphil)

    Automattic Happiness Engineer

    @sergioh4l as this was working previously, you’ll want to first check for conflicts caused by your theme or other plugins. Once you update something on your site, the new code can introduce conflicts where other third-party code isn’t also updated to maintain it’s compatibility.

    We have a guide on how to test for conflicts here:
    https://docs.woocommerce.com/document/woocommerce-self-service-guide/#section-4

    Since those tests will impact the look and functionality of your site, it’s best to do them on a staging site. If you don’t already have a staging site set up, check with your hosting company as many offer this as part of their packages. Otherwise, you can use a free plugin such as WP Staging to set one up.

    Another alternative is to try using the Health Check to run the conflict tests in that guide.

    Hello @fullysupportedphil, thank you for the answer.

    I have deactivated all plugins except WooCommerce and Stripe, I have also activated the Twenty Seventeen theme, but the problem persists.

    What other possible solutions are there?

    Regards.

    Plugin Support Phil

    (@fullysupportedphil)

    Automattic Happiness Engineer

    @sergioh4l Try going to WooCommerce > Settings > Payments > Stripe and turn on Logging.

    Once you do, try loading the page a few times and then check your logs on the WooCommerce > Status > Logs tab. There select the most recent Fatal Errors log as well as the most recent Stripe log to see if they contain any errors.

    If you are still having trouble at that point could you please contact us at WooCommerce.com > My Account > Tickets? You may need to create an account. When opening the ticket, please make sure to select the Stripe plugin. We will be able to help you further there as further troubleshooting isn’t practical via these forums..

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Stripe form not showing’ is closed to new replies.