Support » Plugin: WooCommerce Stripe Payment Gateway » Stripe Credit Card Field is not working

  • Resolved kumarak

    (@kumarak)


    I am using Stripe + Woocommerce on my wordpress site.

    Everything was working fine till 31st dec 2018.

    Later, from 1st of Jan 2019, on checkout page, the Stripe Credit Card field stopped working. The Stripe credit card field is showing very small space + not able to enter any value.

    Here is print screen – https://i.imgur.com/CryVXWh.png

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Phil

    (@fullysupportedphil)

    Automattic Happiness Engineer

    Since this happened suddenly and was working previously, you’ll need to find what changed to cause the error.

    This could be:

    – Code changes on your site (updates or the addition of new plugins/themes)
    – Changes to your Stripe account
    – Changes in your hosting platform

    As a first step, I would recommend enabling logging on for Stripe so that you can see any communication between your site and Stripe. This can be done by going to the WooCommerce > Settings > Payments > Stripe page.

    Once logging is enabled, you can view the logs as they are populated by going to:
    WooCommerce > Status > Logs and selecting the most recent Stripe log.

    If those logs contain errors that you don’t understand, please share them here. Just be sure not to include any sensitive information with your logs.

    You can also try conflict tests to see if any third-party code on your site is causing an issue. We have a guide on how to test for conflicts here:
    https://docs.woocommerce.com/document/woocommerce-self-service-guide/#section-4

    If you don’t already have a staging site set up where you can run those conflict tests, check with your hosting company as many offer this as part of their packages. Otherwise, you can use a free plugin such as [WP Staging](https://en-ca.wordpress.org/plugins/wp-staging/) to set one up.

    Hi Phil,

    I can see there are 02 fatal errors on Logs as shown here: https://i.imgur.com/LT5wTED.png

    And here is detailed information about the error – https://i.imgur.com/H6LIRiG.png

    Would be great if you can have a look and guide how to fix it.

    Plugin Author royho

    (@royho)

    @kumarak These errors are all coming from your theme. I would suggest you contact your theme author about them.

    Thank you for your guidance, it was issue with the function file. It’s now working!!

    @kumarak if you do not mind sharing, what was the specific issue with the function file?
    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Stripe Credit Card Field is not working’ is closed to new replies.