Support » Plugin: WooCommerce » Stripe Connect not working

  • Resolved impackhub

    (@impackhub)


    I have Stripe Connect set up through WooCommerce’s WPNeo Stripe connect Option. Spoke with Stripe and they confirmed at all account settings are correct and card payment option for Connect Standard is working for my area (Canada).

    But when I go to my site’s checkout page, no payment option is displayed. Instead, this message shows:

    “That is the Stripe payment method issue. Make sure, Stripe supported your country and your state. Otherwise, you can’t use this payment method.”

    Strip states that “they [woocommerce] have been retrieving your account object so they should be able to see that charges are enabled. I’m not certain why their plugin is giving you this error. for some reason this plugin for you is showing that your account isn’t able to process payments. As for the issue, it would seem the information they are pulling out from your account is not being read correctly by their plugin, so they do need to look into it.”

    Please investigate.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Praveen

    (@spraveenitpro)

    Automattic Happiness Engineer

    Hi @impackhub

    From what I am reading, you are using the WPNeo stripe connect. can you please instead try with this stripe extension https://woocommerce.com/products/stripe/?aff=10486&cid=1131038 as this is the one we have developed to integrate with WooCommerce. Once you have installed/activated it then you can set it up with [Stripe tutorial](http://docs.woocommerce.com/document/stripe?aff=10486&cid=1131038). Once it is setup then please check if the error persists,

    Cheers!

    impackhub

    (@impackhub)

    Hi Praveen,

    The https://woocommerce.com/products/stripe/?aff=10486&cid=1131038 extension does not support Stripe Connect, which is a feature that I need. For that reason, I cannot use just the basic Stripe extension.

    WPNeo stripe connect is one of the payment options under the WooCommerce menu, though, hence I’d think there is a sync.

    Plugin Support dougaitken

    (@dougaitken)

    Automattic Happiness Engineer

    Hey @impackhub

    If you’re having trouble with the WPNero Stripe plugin, I’d recommend speaking to the plugin team who offer support for that. It isn’t an extension from the core WooCommerce team so we’re unable to offer support.

    As this isn’t related directly to functionality of the core WooCommerce plugin, I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Stripe Connect not working’ is closed to new replies.