Support » Plugin: YITH WooCommerce Stripe » Stripe Checkout can’t communicate with our payment processor

  • ngoran.ahoua

    (@ngoranahoua)


    How can i solve this issue: “Stripe Checkout can’t communicate with our payment processor because the API key is invalid. Please contact the website owner or support@stripe.com .” i already contact stripe, they tell me to contact my woocommerce stripe plugin support because this problem is due to the Stripe integration, made by my woocommerce stripe plugin.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author YITHEMES

    (@yithemes)

    Hello there,

    hope you are doing well! 🙂

    Could you check if the API credentials are correctly set for live and test mode in the plugin options (First the secret key and then the publishable key)?

    Let us know.

    Have a nice day!

    Hi,
    Yes! of course it is well settled.
    I do not have this problem when I activate the official woocommerce stripe plugin.

    Best regards,

    Plugin Author YITHEMES

    (@yithemes)

    Hi there,

    The issue is with the API key. It is likely you are doing one of the following:

    1) Using wrong API keys. Make sure there are no unwanted hidden space or empty characters in the API Key values (from the copy and paste)

    OR

    2) Using your sandbox API keys but you have “Live Mode” enabled in the plugin.

    OR

    3) You have specified your LIVE API keys in the settings but the “Live Mode” is disabled.

    Stripe doesn’t let you use sandbox API keys for live mode transactions and vice versa. So you need to make sure to use the correct API keys. So check all those and let me know how you go after that.

    I just did a transaction with this plugin to make sure the plugin is working properly.

    Check it and let us know any news, please.

    Have a nice day!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.