Support » Plugin: Theme and plugin translation for Polylang (TTfP) » String translations stop working

  • Hello,

    I have problem with string translation. All translations lost and I wrote them again but still is not working. Everything still appears like the plugin is not intalled at all!

    The page I need help with: [log in to see the link]

Viewing 10 replies - 16 through 25 (of 25 total)
  • Thread Starter elliv1989

    (@elliv1989)

    No, It disappeared from there and the translation stopped working. I don’t know why. It is in my plugins but not there.

    And now there is something that has the name main… and I don’t know what is this

    • This reply was modified 1 year ago by elliv1989.
    Plugin Author Marcin Kazmierski

    (@marcinkazmierski)

    this is strange,

    if you correctly added filter with new domain: “setsail-tours” than this domain should by able in setting page for select:

    This is strange,

    if you have correctly added filter with new domain: “setsail-tours” than this domain should be able in setting page:

    https://imgbb.com/kJ2CDnC (section: “WordPress core and admin domains”)

    Thread Starter elliv1989

    (@elliv1989)

    It disappeared look the settings here: https://ibb.co/mtvtSm0

    and the code here: https://ibb.co/8dHJ6x3

    But I have to tell you that the theme is setsail, setsail tours is a plugin: https://ibb.co/XDDrVvY

    Plugin Author Marcin Kazmierski

    (@marcinkazmierski)

    show me “WordPress core and admin domains” section too (settings page), please 🙂

    Thread Starter elliv1989

    (@elliv1989)

    Plugin Author Marcin Kazmierski

    (@marcinkazmierski)

    You’ve got something wrong because your code doesn’t work properly: https://ibb.co/8dHJ6x3

    when you add “$domains[] = “setsail-tours”;

    the name “setsail-tours” will appear in the “WordPress core and admin domains” section. Without this, your translation will still not work. Please add this code: https://ibb.co/8dHJ6x3 for example in functions.php in your theme.

    Thread Starter elliv1989

    (@elliv1989)

    Good morning,

    That’s exactly my problem, as mentioned before, the plugin is like it’s not installed at all.

    Thread Starter elliv1989

    (@elliv1989)

    As you can see here the plugin setsail tours and the plugin setsail core, renamed in the TTfP settings as “main”. I can’t understand why.

    https://ibb.co/b3K7S86

    and the translations of TTfP “main” don’t work of course as you can see here I have the translation

    https://ibb.co/F6kkXYc

    I can understant this, because the plugin is not main but setsail-tours.

    In setsail-tours plugin the code of strings is (‘string’, ‘setsail-tours’) as you can see here.

    https://ibb.co/C5LpQg9

    So I tried the to add “$domains[] = “main”;” but still nothing.

    Why and how the plugin renamed in TTfP settings is a mystery.

    Plugin Author Marcin Kazmierski

    (@marcinkazmierski)

    @elliv1989 I still have no idea how to help you 🙁

    Thread Starter elliv1989

    (@elliv1989)

    yeah, me neither yet. But I’ll figure it out and when I will, I’ll let you know.

Viewing 10 replies - 16 through 25 (of 25 total)
  • The topic ‘String translations stop working’ is closed to new replies.