Support » Plugin: Polylang » String Translations not being saved for Nirvana Theme by Cryout

  • Hi,

    I’m intending to use Polylang with Cryout’s Nirvana Theme,. However, the string translations for this theme revert to the default language when I click save or press enter. Plugins, and default WP strings save correctly, it’s only strings from the theme which don’t save.

    Here is an example of the error generated when I save:

    [14-Sep-2015 22:20:42 UTC] PHP Notice: unserialize() [<a href='function.unserialize'>function.unserialize</a>]: Error at offset 489 of 8060 bytes in /---/wp-content/plugins/polylang/include/mo.php on line 60

    I contacted the theme’s developers for support, and they asked for more information about the error. Is there anything you can tell me that might help fix the problem?

    Permalinks setting: Post name
    Static Front page: It’s set to Your Latest Posts, but the Nirvana Theme generates its own Presentation Page which functions like a static front page.
    Polylang Settings: The language is set from the subdomain name in pretty permalinks

    https://wordpress.org/plugins/polylang/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Update:

    The Cryout developers have told me that the problem is hitting the POST request limit. This is because I have a lot of very long strings at the start of the table, and Polylang is trying to save all of them at once.

    It’s possible to work around this by lowering the number of strings which appear in the table. The default number of rows for me was 20.

    By clicking the Screen Options tab in the dashboard and changing the Strings translations I was able to display fewer rows and save successfully.

    Should I mark this as resolved, since a workaround has been found?

    Sorry, I spoke too soon!

    I am able to add translations for SOME of the strings. but for others saving still doesn’t work. And when saving fails, it resets the strings which I’ve successfully translated.

    So that workaround doesn’t work properly. Can you help fix this issue?

    (Apologies for double-posting. I don’t seem to be able to edit my posts.)

    Hi there,

    I have the same problem:

    “…able to add translations for SOME of the strings. but for others saving still doesn’t work. And when saving fails, it resets the strings which I’ve successfully translated.”

    Using wpCasa Framework and Polylang version 1.7.9.

    The funny thing is, that it used to work just fine until a couple of days ago. Also everything else can be translated easily and savings wouldn’t reset automatically. It is only the strings that you can translate under SETTINGS=>LANGUAGES=>TRANSLATION

    Would be great if one could help… thank you.

    Plugin Support Chrystl

    (@chrystl)

    Hi
    @alibk

    but for others saving still doesn’t work.

    Did you fill these fields with some html or script?

    @mofu
    Please could you open a new topic to avoid to mix informations and answers.

    Hi Chrystl,

    Yes, there is html in some of these fields. Just basic stuff like <img>
    , but quite a lot of it.

    Plugin Support Chrystl

    (@chrystl)

    Please could you rewrite your code by using the code button.

    Sorry! Didn’t realise that would get messed up. Here is a sample of some of the html which I’m using in the Nirvana theme:

    <span id="Introduction">Nelly Cootalot: The Fowl Fleet</span>

    <a title="The Fowl Fleet" href="http://www.nellycootalot.com/the-game/"><span class="dropcap">N</span>elly Cootalot: The Fowl Fleet</a> is currently in production. Join Nelly in this indie adventure game, and rescue birds hypnotised by the villainous Baron Widebeard. She'll meet a delightful cast of characters and face perplexing challenges in her quest for the Treasure of the Seventh Sea.
    <a title="The Fowl Fleet" href="http://www.nellycootalot.com/the-game/"><img class="alignright" src="http://www.nellycootalot.com/wp-content/uploads/2015/05/nelly-wave.png" alt="Nelly Cootalot" /></a><br><br>
    Nelly Cootalot: The Fowl Fleet is being co-developed and published by <a title="Application Systems London" href="http://www.application-systems.co.uk/" target="_blank">Application Systems</a>. In 2013 we ran a successful <a title="Nelly on Kickstarter" href="http://www.kickstarter.com/projects/315061806/nelly-cootalot-the-fowl-fleet-retro-pirate-adventu" target="_blank">Kickstarter Campaign</a> to fund development. Even though the campaign is over, you can still <a title="Nelly Cootalot Pre-order" href="http://www.nellycootalot.com/games/nelly-2/preorder/">pre-order a digital download or boxed DVD of the game</a>.
    <br><br>
    Nelly Cootalot's original adventure <a title="Spoonbeaks Ahoy!" href="http://www.nellycootalot.com/games/spoonbeaks-ahoy">Nelly Cootalot: Spoonbeaks Ahoy!</a> is a free adventure game for Windows. Help Nelly rescue kidnapped birds without spending a daalder.
    <br><br>
    Check out the <a title="Blog" href="http://www.nellycootalot.com/blog/">Blog</a> and subscribe to <a title="Nelly on Twitter" href="https://twitter.com/NCootalot" target="_blank">Twitter</a> and <a title="Nelly on Facebook" href="http://www.facebook.com/pages/Nelly-Cootalot/479990382054808" target="_blank">Facebook</a> for updates.
    Plugin Support Chrystl

    (@chrystl)

    I tested your code above with Nirvana 1.1.3 + Polylang with no other plugins activated and it works.

    Did you try by deactivating *all* your plugins?

    I just deactivated all the plugins apart from polylang, and unfortunately the problem persists.

    As before, I am able to save changes to some of the Nirvana strings. But other strings will fail to save, resetting all the strings I’ve added translations for.

    Just to be clear – there are more fields than the html I posted above. 1 which is about the same length, and 4 which are shorter.

    Thanks so much for helping with this! Do you have any other thoughts?

    Plugin Support Chrystl

    (@chrystl)

    I just deactivated all the plugins apart from polylang

    Even your security plugin?

    Yes, even the security plugin. I didn’t manually undo any of the changes it has made to .htaccess etc., but I deactivated it from the dashboard.

    Plugin Support Chrystl

    (@chrystl)

    Do you have any other thoughts?

    You could delete your failed strings in your Nirvana settings. Rewrite them one by one by in your Nirvana settings by testing at each time if it works in the Strings translation setting.

    Thanks for that suggestion. I cleared all the fields out of Nirvana’s presentation page, and entered them one by one.

    The first few lines worked, then this one failed:

    Join Nelly Cootalot in this nautical point & click adventure game.<br>Coming to Windows, Mac & Linux in 2015.

    However, if I deleted the linebreak it DID work:

    Join Nelly Cootalot in this nautical point & click adventure game. Coming to Windows, Mac & Linux in 2015.

    I tried the big chunk of html I posted earlier. It did not work for me, but I removed the linebreaks and it did.

    There may be other elements of html which are causing the save to fail, but the only one I could identify was the linebreak. If there is a string with a linebreak displayed in the polylang table at the time of saving, the save fails. If there isn’t, then the save is successful.

    Does that help identify the problem at all?

    Plugin Support Chrystl

    (@chrystl)

    Join Nelly Cootalot in this nautical point & click adventure game.
    Coming to Windows, Mac & Linux in 2015.

    Does the Nirvana support team reproduce your issue with this example?

    Saving strings that include <br> works fine on our test site.

    We’ve had reports before of issues saving our theme’s settings input fields/text areas. It took a while to trace those issues to strings that had apostrophes (‘).
    We’ve assumed it was caused by a server limitation (or weird configuration) but it happened in very few cases and we’ve never been able to reproduce it.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘String Translations not being saved for Nirvana Theme by Cryout’ is closed to new replies.