WordPress.org

Forums

Custom Login
[resolved] Strict Standards warnings in WP_DEBUG mode (4 posts)

  1. megalytic
    Member
    Posted 1 year ago #

    Running this plugin in WP_DEBUG mode gives a lot of warning messages:

    Strict Standards: Accessing static property Custom_Login::$settings_api as non static in /var/www/wp-content/plugins/custom-login/custom-login.php on line 260
    
    Strict Standards: Accessing static property Custom_Login::$settings_api as non static in /var/www/wp-content/plugins/custom-login/custom-login.php on line 261
    
    Strict Standards: Accessing static property Custom_Login::$settings_api as non static in /var/www/wp-content/plugins/custom-login/custom-login.php on line 262
    
    Strict Standards: Accessing static property Custom_Login::$settings_api as non static in /var/www/wp-content/plugins/custom-login/custom-login.php on line 263
    
    Strict Standards: Accessing static property Custom_Login::$options_page as non static in /var/www/wp-content/plugins/custom-login/custom-login.php on line 684
    
    Strict Standards: Accessing static property Custom_Login::$options_page as non static in /var/www/wp-content/plugins/custom-login/custom-login.php on line 686
    
    Strict Standards: Accessing static property Custom_Login::$settings_api as non static in /var/www/wp-content/plugins/custom-login/custom-login.php on line 686
    
    Strict Standards: Accessing static property Custom_Login::$sections as non static in /var/www/wp-content/plugins/custom-login/custom-login.php on line 335
    
    Strict Standards: Accessing static property Custom_Login::$settings_api as non static in /var/www/wp-content/plugins/custom-login/custom-login.php on line 668
    
    Strict Standards: Accessing static property Custom_Login::$sections as non static in /var/www/wp-content/plugins/custom-login/custom-login.php on line 668
    
    Strict Standards: Accessing static property Custom_Login::$settings_api as non static in /var/www/wp-content/plugins/custom-login/custom-login.php on line 669
    
    Strict Standards: Accessing static property Custom_Login::$settings_api as non static in /var/www/wp-content/plugins/custom-login/custom-login.php on line 672

    http://wordpress.org/plugins/custom-login/

  2. Austin Passy
    Member
    Plugin Author

    Posted 1 year ago #

    Not sure what would cause this. Might want to restart your server.

  3. Dan Cameron
    Member
    Posted 1 year ago #

    As of PHP version 5.4 E_STRICT has been added to E_ALL, which is the setting that WP uses for error_reporting.
    http://php.net/manual/en/function.error-reporting.php

    At the moment I do not see a way to around this, unless WP_DEBUG mode isn't used.

  4. Austin Passy
    Member
    Plugin Author

    Posted 1 year ago #

    I've just updated my local dev to PHP 5.4 and will update ASAP.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Custom Login
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags