Support » Plugin: ShortPixel Image Optimizer » Strict Standards: Redefining already defined constructor for class WPShortPixel

  • Resolved Aldo

    (@ab_lu)


    Hello

    When DEBUG it on, I get the following output:

    Strict Standards: Redefining already defined constructor for class WPShortPixel in /wp-content/plugins/shortpixel-image-optimiser/wp-shortpixel.php on line 57

    Strict Standards: Redefining already defined constructor for class ShortPixelQueue in /wp-content/plugins/shortpixel-image-optimiser/shortpixel_queue.php on line 26

    Strict Standards: Redefining already defined constructor for class ShortPixelView in /wp-content/plugins/shortpixel-image-optimiser/shortpixel_view.php on line 12

    Maybe you review and clean up your code.

    Cheers,
    Aldo

    https://wordpress.org/plugins/shortpixel-image-optimiser/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author ShortPixel

    (@shortpixel)

    Hi Aldo,

    What version of PHP does your site use? This could be a bug in the PHP version as per https://bugs.php.net/bug.php?id=52160&edit=3

    We are using old-style constructors along with __contstruct in order to support versions of PHP < 5 but they should be ignored in 5.x PHP versions.

    Thank you for your support!

    Plugin Author ShortPixel

    (@shortpixel)

    We close this topic as it was either solved or the customer didn’t follow up.

    Hello, I have the same problem and it was appeared after ~4-5 updates ago. After switching on the plugin at the top of the each page appears three lines of errors given above in TS message. The PHP version is 5.5 and WP 4.2. How to solve this problem?

    Thanks!

    Plugin Author ShortPixel

    (@shortpixel)

    Hi, thanks for letting us know about this issue.

    In order to check what is going on, could you please specify which PHP version it is exactly, 5.5.?

    Of course, the PHP Version: 5.5.19.

    Plugin Author ShortPixel

    (@shortpixel)

    This is a bit confusing, as the bug should have been resolved since PHP version 5.3.3.

    The easiest way to find out what is going on would be to access to your WP admin with a temporary user with access to our plugin, so we can run some tests and see if we spot any possible source for this issue.

    To help you with this, please contact us directly via our contact page and we’ll go from there. We will come back with the results after debugging here.

    Thank you and see you on the other side! 🙂

    I have same problem, btw. PHP 5.5.10

    Plugin Author ShortPixel

    (@shortpixel)

    Hi Nate, sorry to hear you are experiencing this problem.

    This is a technical issue and to see what is causing it, we’d need temporary access to your Admin. Please get in touch with us here http://shortpixel.com/contact so we can further help you. Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Strict Standards: Redefining already defined constructor for class WPShortPixel’ is closed to new replies.