Support » Plugin: Stream » Stream blocking comment moderation, WooCommerce order updates, etc

  • I haven’t tested this fully, because as you can imagine, our #1 priority was to get our stores processing payments properly again. However, we’ve seen this across 3 different sites.

    We recently added Stream across all our client’s sites, excited about the possibilities of it’s tracking capabilities, and integration with MainWP’s extension to send our client’s reports on their sites. We were on the verge of purchasing the extensions to add the WooCommerce tracking to our client’s sites that have an eStore.

    Then yesterday I realized that on our own estore, no subscriptions had been processed for a couple of weeks. We started looking at possible causes and updated several PHP settings, etc. We also noticed that comment moderation wasn’t working. Nor could we trash a subscription (WooCommerce Subscriptions) or an order. Comment moderation appears to work, but upon reloading the comments page in WP admin, nothing had changed. When trying to trash an order or subscription, the URL would change, but the browser would go to a white screen, and going back and refreshing revealed that the action had not taken place.

    None of the PHP and other server setting updates helped. I then disabled several non-essential plugins, including Stream. Suddenly, everything worked fine. On reflection, Stream had been installed about the time the subscriptions stopped processing. I enabled all of those recently disabled plugins, except Stream, and everything has continued to work.

    I then received emails from a client with an estore, he reported the exact same symptoms. Disabling only Stream fixed all issues on his site. I checked a 3rd estore/WooCommerce site, same sypmtoms, same fix. I remembered that on my personal blog (no WooCommerce/estore) that I’d been unable to properly moderate comments recently, so I checked there, same symptom, same fix. So we’ve disabled Stream across all sites now, as we can’t afford to loose basic functionality, and especially can’t have payments on orders and subscriptions not processing.

    I assume that if this were a universal problem, you’d have fixed it by now. So I don’t know if it’s a conflict with another plugin we use, or what. I’d be happy to do what I can to help. We’ll certainly be a little gun-shy about re-enabling the plugin, but are excited about it’s possibilities and so with proper testing, would like to get back to that point. Here’s some basic info to get you started:

    Some general server settings we messed around with, but didn’t seem to affect this problem:

    Web Server Info: Apache/2.2.26 (Unix)
    PHP Version: 5.3.3
    MySQL Version: 5.5.38
    WP Memory Limit: 256 MB
    WP Debug Mode: No
    WP Language: Default
    WP Max Upload Size: 32 MB
    PHP Post Max Size: 32 MB
    PHP Time Limit: 60


    I cross-referenced the plugins running on the WooCommerce sites, and my personal blog (since it has relatively few plugins, but showed the one common symptom), and here’s the plugins they have in common that might be conflicting with Stream:

    All in One SEO Pack Pro*
    Gravity Forms*
    iThemes Security (good possibility)
    MainWP Child
    Subscribe to Comments Reloaded

    The ones with * next to them are premium plugins, but are GNU so I can get you a copy if you don’t have one. As I noted iThemes Security is a good possibility for a possible conflict. I don’t have time to test now, but may tomorrow. It may be a matter of changing it’s settings to work differently, if it is the one conflicting with stream.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Frankie Jarrett


    Hi Tevya, thanks very much for all of the detail here.

    Our team will look into this right away and attempt to reproduce the issues you described here.

    If we need any additional info, we’ll be sure to ping you here in this thread. And if things get serious, we’ll move over to GitHub.

    Thanks again!

    Cool. Thanks!

    Plugin Author Frankie Jarrett


    Hi Tevya,

    As we were preparing an environment to replicate the problem you are describing we saw this notice:

    Were you aware of this? If so, have you already followed these steps?

    Plugin Author Frankie Jarrett


    So far we have not been able to replicate, but we’ll keep trying. We also don’t have the WooCommerce Subscriptions plugin, which seems like a major component of the issue being described here.

    Just to give us the best possible amount of information, would you mind please installing the Send System Info plugin and paste your “Remote Viewing” URL here?

    Thanks again.

    Yes, I saw that notice as well. I looked into their documentation, changed setting appropriately, and am having no problems. Remember that the other site (my personal blog) that was displaying the same symptoms, minus WooCommerce. Since it doesn’t have WC or the Subscriptions plugins at all, I don’t think that the problem lies with those.

    This might sound strange, but does Stream use the GD library at all? It seems at some point my hosting people didn’t install it when upgrading PHP or something. Just had them fix that last night, and wonder if it might have impact on this at all?

    Plugin Author Frankie Jarrett


    Hi Tevya, thanks for the update.

    No, Stream does not use the GD library in any specific way.

    Does your host running PHP 5.3.3 with eAccelerator?

    The reason I ask is because there are known issues with anonymous functions (which Stream uses heavily) not being properly supported with eAccelerator. So it would be nice if we can rule that out.

    Please see this thread:

    Here’s the URL for Send System Info on my personal blog. It doesn’t run WC, but it displayed the same symptom with comments:

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Stream blocking comment moderation, WooCommerce order updates, etc’ is closed to new replies.