Support » Plugin: WP Retina 2x » strange view in media library and not working

  • Resolved mmtomm



    I installed this on a woocommerce 2.0.4 dev-evironment with a responsive theme “replete from kriesi” and also installed the plugin Enable Media Replace.
    In the media library Media > Retina there is a lot of space between the lines see screenshot here

    also the sizes below the image are missing as described in the manual, as well as the re-upload button.

    In my settings I see also an option for html rewrite, for which I did not find the descrition on

    and beside it has worked to generate all images, it does not seem to work. I switched to debug mode, disabled styleshhets with firebug to see the image properties and no image has the retina ..@2x..
    I tried in server and client side mode.

    any idea what is wrong with me?

    Thank you

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Jordy Meow


    Hello 🙂

    Okay, so first: no need to install the Enable Media Replace anymore. There is a replace function within the retina plugin. You can use the Retina Dashboard for that, and drag & drop your file within it. That said, you can also use Enable Media Replace, it’s just a bit less convenient (too many clicks).

    Many spaces, indeed 🙂 It seems you have a LOT of image sizes registered in your WordPress. Are you really using them all!? Do you need them all to be retinized as well? You can go in the settings of the plugin and tick the sizes you don’t need. Once cleaned, this issue should disappear. But it’s true I should do something about it, it is just I never encountered such a case (though I am not surprised).

    You right, the article on Totoro Times needs to be refreshed. The plugin changed a lot since I wrote that article. The HTML Rewrite is very knew, and is the method I now recommend. But beware! Do you use a caching plugin? Disable it first. The HTML Rewrite doesn’t work with caching yet (or maybe it depends which system, but it doesn’t work with W3 Total Cache for now – I am discussing with the developer to find a solution, there are many).

    Hi Jordy,

    thank you for that quick response!
    I disabled some image sizes and now it fits into the page.
    When you mention the retina dashboard, do you mean the MEDIA > RETINA? I do not find something else in my backend.
    However, I disabled “Enable Media Replace” and deleted the plugin. But within the images in retina I still only see the options “generate” and “ignore” but not the upload button…

    Thank you

    Plugin Author Jordy Meow


    True… It used to be called the Retina Dashboard but for personal reason, I changed it 😉

    There is no upload button. If you want to replace an image, just drag and drop a file on the image on the file you want to replace. No need to click any button or anything, just drag & drop the file! That way you can replace a lot of files at the same time without clicking. Am I clear? Maybe I should write this on the Totoro Times article as well.

    OK, clear now.

    Only the debug mode is not clear to me yet: I enabled it with server side mode and tried to check my images. Due to my theme I need to disable CSS with the web developer toolbar so that I can acess the image properties. shouldnt I see now the image file name has some @2x added to it, and shouldnt it be twice the size as my themes image configuration for that particular image?

    sorry to bother you, but I will follow your instruction soon and post a totoro times page on my 2k+ facebook page – promise! (If you prefere a specific one pls let me know)


    Plugin Author Jordy Meow


    Server-side method, no, you will not see the @2x added to it. With the Client-side neither (though you could see it being loading using the web developer tools). With the HTML Rewrite though, you will definitely see the @2x (if the images can be found). And of course, there are twice the size 🙂

    Please post your website here so that I can double-check.

    Haha, thanks a lot for the post, that would be cool 🙂 An article about Gunkanjima, or Nara Dreamland. They are the favorites 🙂

    the page is not accessible yet from outside.

    I posted your overview article, cause I felt, this is the best entry for it Gunkanjima Odyssey via my FB-Page

    Greetings from Vienna

    sorry, one more question:
    I detected this one in my PHPerrorLog:
    PHP Warning: DOMDocument::loadHTML(): Empty string supplied as input in …/wp-content/plugins/wp-retina-2x/wp-retina-2x.php on line 92

    Line 92 is the bold one:

    function wr2x_html_rewrite( $buffer ) {
    	$doc = new DOMDocument();
    	<strong>$doc->loadHTML( $buffer );</strong>

    must I worry?

    Best Regards

    Plugin Author Jordy Meow


    Thanks a lot for sharing that page, it’s perfect 🙂

    You shouldn’t worry, it’s not an actual issue. It just a bit weird, it means that sometimes, your WordPress generates an empty page. I am not sure why. It is not related to the plugin though, and the “warning” is therefore maybe not relevant, rather useless. In the next release, you will not see it anymore (if the $buffer is empty, I will return empty without going through all this function here).

    Is it working well by the way?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘strange view in media library and not working’ is closed to new replies.