WordPress.org

Support

Support » Multisite » Strange URL constuction with multisite

Strange URL constuction with multisite

  • When I create a site (under a multisite setup), the path to the site getting constructed incorrectly. (NOTE: I have 3b2 set up to create sites as sub-domains.)

    I’m getting a path that looks like this:

    http://test.www.domain.comdatabasename/

    The .com is followed immediately by what appears to be the name of the mysql database for the WP installation. Is that just a strange coincidence? I’ve had this result twice. Weird.

    Earlier, I came across a help page (possibly in the codex?) that said that the www. should be removed from one of the places in setup where the base URLs are entered. I assume that accounts for the www in the above URL following the subdomain. But can’t locate that help page again, and for some reason I also can’t locate the setup page where that info is specified (does it get moved once MULTISITE is enabled?)

    Thanks!

Viewing 15 replies - 16 through 30 (of 47 total)
  • I do have pretty permalinks on the main blog, yes.
    “/%category%/%postname%/”

    Not sure how I would ‘put the htaccess file there correctly’ though. I didn’t think when you changed your permalinks that you needed to do anything with the htaccess.

    Right now I’m unable to see my htaccess in my mymythos.org folder, but I believe that’s because it’s a hidden file. Could be wrong though.

    Not sure how I would ‘put the htaccess file there correctly’ though.

    Gah, I meant when you set up the network initially, did you put the new rewrite rules in the htaccess file?

    Yeah, it’s a hidden file.

    On some systems, mod_rewrite is enabled, pretty permalinks work, but for some reasons it’s just not reading the .htaccess file correctly, so it won’t serve up the subfolder blogs.

    And normally, yes, if you change permalinks on a single install, it edits the htaccess file for you (if it can) or warns you to put some edits in (if not there).

    See here:
    http://codex.wordpress.org/Permalinks#Fixing_.htaccess_Generation_Issues

    Yes! I remember putting in the new rules, but perhaps I did them wrong. I’ll check that out.

    I told Cyberduck to ‘show hidden files’ though and the htaccess still isn’t visible unless I do a file search for it which is strange. Shouldn’t it be in the mymythos.org folder?

    Yep, shoudl be there.

    If it’s not, that’d be the issue.

    Hm, so it is there and this is what it says:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>
    
    # END WordPress

    Yep, looks right. What about your wp-config.php file?

    wpconfig…

    <?php
    /** WordPress's config file **/
    /** http://wordpress.org/   **/
    
    // ** MySQL settings ** //
    define('WP_CACHE', true); //Added by WP-Cache Manager
    define('DB_NAME', '*******');     // The name of the database
    define('DB_USER', '******');     // Your MySQL username
    define('DB_PASSWORD', '*******'); // ...and password
    define('DB_HOST', '*******');     // ...and the server MySQL is running on
    
    // Change the prefix if you want to have multiple blogs in a single database.
    
    $table_prefix  = 'wp_';   // example: 'wp_' or 'b2' or 'mylogin_'
    
    // Turning off Post Revisions. Comment this line out if you would like them to be on.
    
    define('WP_POST_REVISIONS', false );
    
    // Change this to localize WordPress.  A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    
    define('WP_ALLOW_MULTISITE', true);
    
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'www.mymythos.org' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    
    define( 'AUTH_KEY', 'i@(&gk9||49 TC!!7 ko=_Tr3u,EK@lvHekPW,,DN^R5)hmr;eM3R|ZwqX+;n)u6' );
    define( 'SECURE_AUTH_KEY', '~|saaYHr~{!z>}dTRjI9QUo=oH=D1Xnj|SdL8&O9BkT|*=WX@X?^Rd)).&s>p}=[' );
    define( 'LOGGED_IN_KEY', 's4gA{]=_PGMdm8~EyW7HeH7DUh7VXOWD1h9_|Ts}=~u$F6n&XVHhPq$<2bbF@7uQ' );
    define( 'NONCE_KEY', '=3;SH^9n~Jb2}xt=X.SotJ#-!j* KGfLI.-0W|oJKS,jgngT,[TsC.1CqF*X494s' );
    define( 'AUTH_SALT', '6(N@U@ao+eYz[!|Qg(t;Xj$?xv4|TJ&#

    an!yqN0I_%zrF w.t/hqcfP<+s[rh!-‘ );
    define( ‘SECURE_AUTH_SALT’, ‘<?bovaai(jx=Q<97=RPfpx>P2/[ZSW`u8-&iG;Jde]65tqe@RA2Z|^ =9.XIiU$s’ );
    define( ‘LOGGED_IN_SALT’, ‘I6edq3EHS4GGja-zM*Hnb=YZ&Q{hVgpa4{Xh5A]qM]Q@{fY|]e2=8L+mzxc_;u’ );
    define( ‘NONCE_SALT’, ‘e+^l)Jc4}/&uGU~I;c.Dt&-S&A@UfNoy[50+k^#5m/X(JAO%xe<^lQu4TxWI2{]n’ );

    /* Stop editing */

    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;

    define(‘ABSPATH’, dirname(__FILE__).’/’);

    // Get everything else
    require_once(ABSPATH.’wp-settings.php’);
    ?>
    `

    * mod edit: obfuscated db username & password *

    Sorry it jumped out of the code box somehow.

    Sorry it jumped out of the code box somehow.

    Here is a pic of the Sites area and the weird site names/URLS

    View post on imgur.com

    So I’ve been studying the wp-config a bit but still am not quite sure what would cause the strange URLs.

    Andrea do you see anything in there that would be the culprit?

    Any help? Feels like were really close, and I know other people are having this issue as well.

    I can’t see anything wrong in anything you’ve posted.

    Have you checked with your webhost? I do know Dreamhost (for example) will not support the network on their shared plans, and have quite possibly disabled it from working.

    Considering you fixed it and it came right back, my suspicion is host-related.

    Talked to DreamHost (my host coincidentally) and they said it appears to be a software issue with WP. I do seem to remember WP stating something about how “there is already a version of 3.0 present” or something to that effect, perhaps that’s doing it.

    In the meantime I think I’ll have to just completely reinstall WP, hopefully without losing my posts, URLS, and theme customizations…ugh.

    Is there a better way here?

    Right, but if WordPress is detecting another network, and you’re using a fresh clean database…

    then signs point to the host and how they’ve set up the box. 😉 (they like to pass the buck)

Viewing 15 replies - 16 through 30 (of 47 total)
  • The topic ‘Strange URL constuction with multisite’ is closed to new replies.