Support » Fixing WordPress » Strange Upload Error in 2.5

  • Okay, I know there are a lot of “Upload error” threads on the forum already, and I’ve read a lot of them. I’ve even read the Upload Error sticky on the page, and following some of those steps, I have managed to get the upload to work, although with some weird kinks.

    Here are my issues:

    I’ve been uploading pics with 2.5 since it was released and it has been swell. No problems at all. And then last night, out of the blue, I get error messages while the images are crunching:

    “HTTP error.” and “An error occurred in the upload. Please try again later.”

    So following some steps I read here, I activated the plugin to disable the flash uploader (“No Flash Uploader” plugin), which sorta fixes the problem. The image uploads and stores just fine, creates thumbnails, all that good stuff, but I still get the below message:

    “Specified file failed upload test.”

    Again, the images upload just fine, and I can use it on the site, but I’m worried about the message, and if possible, I’d really like to use the flash loader, since it’s more convenient and I can select a full gallery instead of doing it one pic at a time.

    I’ve contacted my web host and they say nothing was done to my server, so the issue isn’t on their end. Plus, I’ve followed all the recommendations to add lines of code to the htaccess with no success.

    Any thoughts, anyone?

Viewing 4 replies - 1 through 4 (of 4 total)
  • dont know but I have exactly the same problem

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    “Specified file failed upload test” means that, basically, PHP reported that the uploaded file was not uploaded.

    WordPress checks the PHP function call is_uploaded_file, and returns that message on a failure.

    Unfortunately, that doesn’t tell you why it failed, just that it did. Maybe the hosts’ tmp directory is full, maybe they’ve disabled uploads, maybe the file was too big, who knows?

    I’ve found reducing the image sizes down to 1024×768 and then uploading them seems to fix it. No large photos on the site, but it’s a workaround…

    Hi, Otto. No, it’s nothing to do with my host. But as I mentioned, after I disabled the flash upload, it does upload, but it gives me that “Specified file failed upload test” message, although the image DOES in fact upload, and I can use them, which I have been doing since yesterday. I just can’t figure out anything else, I’ve tried pretty much EVERY suggestion people have.

    I guess it’s just a bug or something?

    P.S. I have WordPress 2.5 on four other blogs, and it only happens with one of them. Weird.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Strange Upload Error in 2.5’ is closed to new replies.