WordPress.org

Forums

Strange update problem (2.6 - 2.6.3) (3 posts)

  1. ghostboy
    Member
    Posted 6 years ago #

    Hi..

    Some mofo managed to hack my blog.. I had my index.php replaced with some kind of middle-eastern rant.

    I decided to upgrade. Couldn't find anything relevant online as to why this happened.

    Anyway.. Replaced wp-admin and wp-includes etc.

    Blog now works as before.. BUT.. I can't get in to the admin.

    When I try to access it I get a pop-up dialog box requiring a username/password. I've tried my previous log-in details, they don't work.

    When I click cancel, I get the following error:

      You are not authorized to view this page
      You do not have permission to view this directory or page due to the access control list (ACL) that is configured for this resource on the Web server.

    What is this? How can I fix it?

    Appreciate any help!

    http://www.kidcapricious.com

  2. Samuel B
    moderator
    Posted 6 years ago #

    Hi
    that is a password protect box from your host - not wordpress.
    You should report the hack to them and ask them to look into it as they may have compromised more sites across the server.
    If you didn't set the /wp-admin folder for password protect, ask them to fix this.
    You really should go through the files you didn't replace just to see if there is extraneous code.
    Also, review this:
    http://codex.wordpress.org/Hardening_WordPress

  3. ghostboy
    Member
    Posted 6 years ago #

    THanks for your help. :)

Topic Closed

This topic has been closed to new replies.

About this Topic