Support » Plugin: W3 Total Cache » Strange symbols

  • It worked beautiful until recent update. Now each page of my web site displays strange symbols when this plugin is turned on. These symbols disappeared after reloading, but appeared on new pages.

    I had to disable this plugin. Hope to see it fixed soon.

    • This topic was modified 2 years, 9 months ago by  Tom.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi

    We had this same problem and applied the fix by switching the PgCache_ContentGrabbber.php file with the new version. This then caused the admin bar to be visible at all all times to visitors of the site. I rolled the file back and changed just the suggested line 1244 with the fix and the admin bar problem went away.

    Any idea why this might be happening?

    Many thanks

    Hi @leanda … Curious…when you say you “switched the PgCache_ContentGrabbber.php file with the new version” can you be more specific?

    When switching the PgCache_ContentGrabbber.php file you would need to do it this way:

    1. Clicked the link Nigro gave above
    2. Clicked the Files Changed tab
    3. Clicked the View button
    4. Clicked the Raw button
    5. Then within your browser you Save As (in Chrome) or Save Page As (in Firefox) — to save the page as a raw .php file to disk.
    6. Upload that saved file to your server

    Then that would have been correct. The only change in that saved file is just line 1244. It should work just fine — no admin bar glitch.

    However, if you did it in a different way (e.g. you went to the main site page — away from Nigro’s link — and downloaded the w3tc-fixed zip file so as to extract the PgCache_ContentGrabbber.php) there is a chance the file you downloaded includes other changes…changes that might depend on other changed files that you didn’t get/seeing. So it all depends on what you did.

    The easiest approach in this context is to just modify line 1244 manually, as you discovered.

    Regards
    Kimberly

    • This reply was modified 2 years, 9 months ago by  Kimberly.
    • This reply was modified 2 years, 9 months ago by  Kimberly.
    • This reply was modified 2 years, 9 months ago by  Kimberly.

    Yup, I implemented the fix exactly as you describe in the steps above, replacing the full file and in the end rolled back to the old version of the file and just replaced line 1244, which solved the symbols issue and also the admin bar issue.

    If I replace the PgCache_ContentGrabbber.php from the RAW version it introduces the admin bar issue for us.

    hi again @leanda … very interesting. I am at a loss. When i do a file compare the only change is line 1244.

    For the fun of it i will download a fresh official copy of v0.9.5.2 right now (i assume you haven’t changed anything else in your files besides that 1 line) and use the exact steps to modify the file and see if i can hopefully get the admin page glitch you are seeing. I will update what i find.

    Thanks for the info
    Kimberly

    Hi again @leanda

    Update:

    Seemed to work fine (no admin bar). My steps were:

    1. Switched my server environment to use PHP v5.3
    2. Installed a fresh copy of v0.9.5.2 in my WordPress 4.7.2
    3. Turned on Page Cache & Minify and navigated my website
    4. Saw the garbled (strange) symbols you were originally getting
    5. Followed the steps above to download the raw file of PgCache_ContentGrabbber.php.
    6. Uploaded this new file via FTP to the w3-total-cache directory
    7. Flushed All Caches
    8. While on the Admin page i visited the website just to see the admin bar…perfectly normal to see the bar while logged in. I navigated to several pages. I also checked the cache directory (via FTP) to verify that these pages were not being cached (since my setting is to not cache pages for logged in users)
    9. I logged out of admin page
    10. I navigate to my website and visit several pages. I see no Admin bar
    11. I check via FTP to see the pages are now being cached to disk — they are.

    Conclusion:

    So i get a sense it may have been something else that was causing the problem because i was not able to duplicate your issue, unfortunately.

    From what you’re saying your admin pages were being cached when you were logged in. Or i wonder if you were actually logged still, after the change, when this was happening?

    If you have the means to do some experimentation i’d love to get more info to see if it indeed still happens on your end — ensuring you are logged off after making the change. And seeing if these admin pages are being cached to disk.

    Thanks for the info
    Kimberly

    Same problem here. Hope that the plugin author fixes the problem.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Strange symbols’ is closed to new replies.